summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Rys2021-06-15 15:08:08 +0200
committerMartin Rys2021-06-15 15:08:08 +0200
commit465b5821311704fb95327e503eb4d7518c73e019 (patch)
tree8f4faea430ae0a021646b29ab5432422bb812b6b
parent61e37e17b093eb193c67d6d4d506dab1ebb54437 (diff)
downloadaur-465b5821311704fb95327e503eb4d7518c73e019.tar.gz
bump to 0.16.1[0.16.3]
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b7977b62c73..6858e4a40f15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = loot
pkgdesc = A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games.
- pkgver = 0.16.0
+ pkgver = 0.16.1
pkgrel = 3
url = https://loot.github.io
arch = x86_64
@@ -24,12 +24,11 @@ pkgbase = loot
depends = libxrandr
depends = libxss
depends = libxtst
- source = loot-0.16.0.tar.gz::https://github.com/loot/loot/archive/0.16.0.tar.gz
- source = libloot-0.16.2.tar.gz::https://github.com/loot/libloot/archive/0.16.2.tar.gz
+ source = loot-0.16.1.tar.gz::https://github.com/loot/loot/archive/0.16.1.tar.gz
+ source = libloot-0.16.3.tar.gz::https://github.com/loot/libloot/archive/0.16.3.tar.gz
source = LOOT.desktop
- sha256sums = b501d73e9bc00e86dc6d14b8c5f5b96effaa7c7dca654e1768c6eabdd36b887d
- sha256sums = 13d815ab3aaf90c58135932d7fa5f40e44c190ab63e756f0a953ee44800ed197
+ sha256sums = 7e7356d7b8d6d75924805d8e2b8e2cac69797ab203a18f6a1d12090f01a8c7f3
+ sha256sums = 6c2ff8bab81aeec74efb83fd6ee9754dde63c09349937c9a9b397fe92cbe2829
sha256sums = 3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb
pkgname = loot
-
diff --git a/PKGBUILD b/PKGBUILD
index f608494ed107..20025124035c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: John Troxler <firstname dot lastname at gmail dot com>
+# Co-Maintainer: Martin Rys <https://rys.pw/#contact_me>
pkgname=loot
-# Remove spotify hax on next version bump!
-pkgver=0.16.0
-_pkglibver=0.16.2
+pkgver=0.16.1
+_pkglibver=0.16.3
pkgrel=3
pkgdesc="A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games."
arch=('x86_64')
@@ -15,8 +15,8 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$
"lib$pkgname-$_pkglibver.tar.gz::https://github.com/$pkgname/lib$pkgname/archive/$_pkglibver.tar.gz"
'LOOT.desktop'
)
-sha256sums=('b501d73e9bc00e86dc6d14b8c5f5b96effaa7c7dca654e1768c6eabdd36b887d'
- '13d815ab3aaf90c58135932d7fa5f40e44c190ab63e756f0a953ee44800ed197'
+sha256sums=('7e7356d7b8d6d75924805d8e2b8e2cac69797ab203a18f6a1d12090f01a8c7f3'
+ '6c2ff8bab81aeec74efb83fd6ee9754dde63c09349937c9a9b397fe92cbe2829'
'3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb'
)
@@ -25,6 +25,8 @@ sha256sums=('b501d73e9bc00e86dc6d14b8c5f5b96effaa7c7dca654e1768c6eabdd36b887d'
#}
build() {
+ # hack as per Comments page
+ find ./ -type f -exec sed -i 's#--config $(CONFIGURATION)##g' {} \;
# libloot
cd "$srcdir/lib$pkgname-$_pkglibver"
yarn install
@@ -41,8 +43,6 @@ build() {
# loot
cd "$srcdir/$pkgname-$pkgver"
yarn install
- # Spotify Hax because of domain change
- sed -i 's,opensource.spotify.com/cefbuilds,cef-builds.spotifycdn.com,g' CMakeLists.txt
# Cripple update check, always return no update available
echo 'export default async function updateExists(currentVersion: string, currentBuild: string){if(currentVersion === undefined || currentBuild === undefined || true) {return false;}}' > src/gui/html/js/updateExists.ts
mkdir -p build
@@ -62,12 +62,11 @@ package() {
install -Dm644 -t "$pkgdir/opt/$pkgname" \
"$_builddir/icudtl.dat" \
- "$_builddir/external/src/cef/Resources/cef_extensions.pak" \
"$_builddir/snapshot_blob.bin" \
"$_builddir/v8_context_snapshot.bin" \
- "$_builddir/cef.pak" \
- "$_builddir/cef_100_percent.pak" \
- "$_builddir/cef_200_percent.pak"
+ "$_builddir/resources.pak" \
+ "$_builddir/chrome_100_percent.pak" \
+ "$_builddir/chrome_200_percent.pak"
install -Dm644 -t "$pkgdir/opt/$pkgname/resources/l10n" \
"$_builddir/external/src/cef/Resources/locales"/*.pak