summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPrzemysław Buczkowski2018-06-04 22:13:37 +0200
committerPrzemysław Buczkowski2018-06-04 22:13:37 +0200
commitd5a686999b0c763148ae50dbdaf5cc866827d746 (patch)
tree89481ceb9f9cf986c2fea0bde0177989f6359603
downloadaur-lotterhoffcrash.tar.gz
Ku chwale trójki!
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
-rwxr-xr-xlauncher8
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd1c6b47974a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lotterhoffcrash
+ pkgdesc = Enhance your Arch Linux experience with Miss Lotterhoff and Mr Dobecki
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://1mi.pl/~lachcim/wa%c5%bcne%20programy/
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = wine
+ depends = wine-mono
+ source = launcher
+ source = https://1mi.pl/~lachcim/wa%c5%bcne%20programy/lotterhoffcrash.exe
+ md5sums = 4e4996896dcc7252a3aba80627c55636
+ md5sums = a464cbac89bf42cb3a3d120b022e11be
+
+pkgname = lotterhoffcrash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c35acf21ae0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Przemysław Buczkowski <przemub@przemub.pl>
+
+pkgname=lotterhoffcrash
+pkgver=1.0
+pkgrel=1
+pkgdesc="Enhance your Arch Linux experience with Miss Lotterhoff and Mr Dobecki"
+arch=(i686 x86_64)
+url="https://1mi.pl/~lachcim/wa%c5%bcne%20programy/"
+license=('unknown')
+depends=(wine wine-mono)
+source=(launcher https://1mi.pl/~lachcim/wa%c5%bcne%20programy/lotterhoffcrash.exe)
+md5sums=('4e4996896dcc7252a3aba80627c55636'
+ 'a464cbac89bf42cb3a3d120b022e11be')
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cp launcher $pkgdir/usr/bin/lotterhoffcrash
+
+ mkdir -p $pkgdir/opt
+ cp lotterhoffcrash.exe $pkgdir/opt
+}
diff --git a/launcher b/launcher
new file mode 100755
index 000000000000..44dc5e399fcc
--- /dev/null
+++ b/launcher
@@ -0,0 +1,8 @@
+#!/bin/bash
+export WINEARCH=win32 WINEPREFIX="$HOME/.lotterhoffcrash/wine"
+export WINEDLLOVERRIDES="mshtml="
+
+mkdir -p "$HOME"/.lotterhoffcrash/wine || exit 1
+
+wine /opt/lotterhoffcrash.exe
+