summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormasutu2015-07-06 22:46:24 +0200
committermasutu2015-07-06 22:46:24 +0200
commit12eb024882f0fd55c3b5a69a7368aa72c8c1bf95 (patch)
treec06f711bc182c75dc63d940f9f5e1c61e5737ad2
downloadaur-louderbox.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adbb9e3290af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = louderbox
+ pkgdesc = A complete 8 band audio processor using the jack audio connection kit.
+ pkgver = 0.1.0
+ pkgrel = 3
+ url = http://nixbit.com/cat/multimedia/audio/louderbox/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = jack
+ depends = libglade
+ depends = swh-plugins
+ depends = tap-plugins
+ source = http://www.sourcefiles.org/Multimedia/Mixers/louderbox-0.1.0.tar.gz
+ md5sums = d3e0eeeff6282e703c1da38cd696e830
+
+pkgname = louderbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f007949d2ddc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: masutu <masutu dot arch at googlemail dot com>
+# Maintainer: masutu <masutu dot arch at googlemail dot com>
+
+pkgname=louderbox
+pkgver=0.1.0
+pkgrel=3
+pkgdesc="A complete 8 band audio processor using the jack audio connection kit."
+arch=('i686' 'x86_64')
+url="http://nixbit.com/cat/multimedia/audio/louderbox/"
+license=('GPL')
+depends=('jack' 'libglade' 'swh-plugins' 'tap-plugins')
+source=(http://www.sourcefiles.org/Multimedia/Mixers/$pkgname-$pkgver.tar.gz)
+md5sums=('d3e0eeeff6282e703c1da38cd696e830')
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ LDFLAGS="-ldl" ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
+ make
+}
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 README $pkgdir/usr/share/${pkgname}/README
+ install -m644 AUTHORS $pkgdir/usr/share/${pkgname}/AUTHORS
+}
+
+# vim:set ts=2 sw=2 et:
+