summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblubbblubb2019-08-02 16:12:48 +0200
committerblubbblubb2019-08-02 16:12:48 +0200
commit514b859a8a61953b1101c856ff9f82dc4c45b06d (patch)
tree3365686fa6a6bd1262f6ba6fc7300e4cc75638dc
parent4f92064979f7dfef75cffe2ca6035e168e257d75 (diff)
downloadaur-514b859a8a61953b1101c856ff9f82dc4c45b06d.tar.gz
update to v0.5.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
-rw-r--r--ffmpegInputBuffer.patch4
3 files changed, 11 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a605b2488048..e36950947dbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = loudgain
pkgdesc = A loudness normalizer that scans music files and calculates loudness-normalized gain and loudness peak values according to the EBU R128 standard, and can optionally write ReplayGain-compatible metadata.
- pkgver = v0.3.2
+ pkgver = v0.5.0
pkgrel = 1
url = https://github.com/Moonbase59/loudgain
arch = i686
arch = x86_64
license = BSD 2-Clause "Simplified" License
+ makedepends = cmake
depends = taglib
depends = libebur128
- depends = libavresample
+ depends = ffmpeg
provides = loudgain
provides = rgbpm.sh
- source = https://github.com/Moonbase59/loudgain/archive/v0.3.2.tar.gz
- source = ffmpegInputBuffer.patch
- sha256sums = 0c2197f53686b6e336d766f38c120817f73626e1dc33a682ed3e6ce037f26099
- sha256sums = 34e637879b89437bf1098966e48174ec805ef6e5aa13d36cbd769a4077bfdde6
+ source = https://github.com/Moonbase59/loudgain/archive/v0.5.0.tar.gz
+ sha256sums = 001a8862a13b8bf7f0c8ab10775aa2e5e2e5ece2a1f0b3c51e9f7c9118d9d488
pkgname = loudgain
diff --git a/PKGBUILD b/PKGBUILD
index 1629fddc6dfc..9d7c326a3d81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,18 @@
# Maintainer: blubbblubb <lampadada[removeme][at]googlemail[dot]com>
pkgname=loudgain
-pkgver=v0.3.2
-_pkgver=0.3.2
+pkgver=v0.5.0
+_pkgver=0.5.0
pkgrel=1
pkgdesc="A loudness normalizer that scans music files and calculates loudness-normalized gain and loudness peak values according to the EBU R128 standard, and can optionally write ReplayGain-compatible metadata."
url="https://github.com/Moonbase59/loudgain"
arch=('i686' 'x86_64')
license=('BSD 2-Clause "Simplified" License')
-depends=("taglib" "libebur128" "libavresample")
+depends=("taglib" "libebur128" "ffmpeg")
+makedepends=('cmake')
provides=('loudgain' 'rgbpm.sh')
-source=("https://github.com/Moonbase59/loudgain/archive/$pkgver.tar.gz"
- "ffmpegInputBuffer.patch")
-sha256sums=('0c2197f53686b6e336d766f38c120817f73626e1dc33a682ed3e6ce037f26099'
- '34e637879b89437bf1098966e48174ec805ef6e5aa13d36cbd769a4077bfdde6')
-
-prepare() {
- patch "${srcdir}/${pkgname}-${_pkgver}/src/scan.c" "${srcdir}/ffmpegInputBuffer.patch"
-}
+source=("https://github.com/Moonbase59/loudgain/archive/${pkgver}.tar.gz")
+sha256sums=('001a8862a13b8bf7f0c8ab10775aa2e5e2e5ece2a1f0b3c51e9f7c9118d9d488')
build() {
cd "${srcdir}/${pkgname}-${_pkgver}"
diff --git a/ffmpegInputBuffer.patch b/ffmpegInputBuffer.patch
deleted file mode 100644
index dbee7d5661f9..000000000000
--- a/ffmpegInputBuffer.patch
+++ /dev/null
@@ -1,4 +0,0 @@
-109c109
-< int buffer_size = 192000 + FF_INPUT_BUFFER_PADDING_SIZE;
----
-> int buffer_size = 192000 + AV_INPUT_BUFFER_PADDING_SIZE;