summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-01-16 22:06:47 +0100
committerGustavo Alvarez2016-01-16 22:07:30 +0100
commit15dfd3f4e1a1b484dafa567ae9eb82b8edf24a44 (patch)
tree44e57e5166fbdf502276408fcc39f672b2f2d27e
parent76a429be43a88de655708e3963aad3de6d44fdbb (diff)
downloadaur-15dfd3f4e1a1b484dafa567ae9eb82b8edf24a44.tar.gz
OpenPegasus site don't like wget/curl. switch to use lynx (use a lynx script for automatization download)
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
-rw-r--r--lynx_script_for_download_pegasus7
4 files changed, 19 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c941453081a7..ccd5e23913b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Jan 11 11:30:59 UTC 2016
+# Sat Jan 16 21:02:06 UTC 2016
pkgbase = lsi-msm
pkgdesc = LSI Logic MegaRAID Storage Manager Suite
pkgver = 15.11.00.13
@@ -13,6 +13,7 @@ pkgbase = lsi-msm
makedepends = icu
makedepends = openslp
makedepends = sqlite
+ makedepends = lynx
depends = libxtst
depends = alsa-lib
depends = libnet
@@ -37,6 +38,7 @@ pkgbase = lsi-msm
backup = usr/share/MegaRAID_Storage_Manager/MegaPopup/vivaldikey.properties
backup = usr/share/MegaRAID_Storage_Manager/MegaPopup/vivaldikeys
backup = usr/share/MegaRAID_Storage_Manager/MegaPopup/vivaldikeys2048
+ source = lynx_script_for_download_pegasus
source = https://collaboration.opengroup.org/pegasus/documents/32572/pegasus-2.14.1.tar.gz
source = msm_profile.sh
source = LSI_StorSNMP.ini
@@ -49,6 +51,7 @@ pkgbase = lsi-msm
source = http://pkgs.fedoraproject.org/cgit/tog-pegasus.git/plain/pegasus-2.13.0-gcc5-build.patch
source = http://pkgs.fedoraproject.org/cgit/tog-pegasus.git/plain/pegasus-2.14.1-build-fixes.patch
source = http://pkgs.fedoraproject.org/cgit/tog-pegasus.git/plain/pegasus-2.14.1-ssl-include.patch
+ sha1sums = 3e0e9a5b5bae72af361db01825242aefcfc3094a
sha1sums = c832eaf240f6dfba843c4937f7a935382d48b9be
sha1sums = 0e5d7b71435760e3ef7c1e132ba05145ccbd1268
sha1sums = 79fbe24898030db50295a6254e7c4627e2b51b7c
diff --git a/.gitignore b/.gitignore
index 0fa152170faf..0d30ef143de6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -8,3 +8,4 @@
!lsi-msm.install
!msm_profile.sh
!ld.so.lsi-msm.conf
+!lynx_script_for_download_pegasus
diff --git a/PKGBUILD b/PKGBUILD
index d785951b3246..4c5538d23ed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,12 +35,15 @@ depends_x86_64=('lib32-libxi'
makedepends=('icu'
'openslp'
'sqlite'
+ 'lynx'
)
-DLAGENTS=('https::/usr/bin/wget -c -t 3 --waitretry=3 -O %o %u'
+ # OpenPegasus site don't like wget/curl. :/
+DLAGENTS=('https::/usr/bin/lynx -accept_all_cookies -cmd_script=lynx_script_for_download_pegasus %u'
'http::/usr/bin/curl -qb "" -fLC - --retry 3 --retry-delay 3 -o %o %u')
-source=('https://collaboration.opengroup.org/pegasus/documents/32572/pegasus-2.14.1.tar.gz'
+source=('lynx_script_for_download_pegasus' #IMPORTANT for download pegasus zip. please don't move to other place
+ 'https://collaboration.opengroup.org/pegasus/documents/32572/pegasus-2.14.1.tar.gz'
'msm_profile.sh'
'LSI_StorSNMP.ini'
'lsi_msm.service'
@@ -54,7 +57,8 @@ source=('https://collaboration.opengroup.org/pegasus/documents/32572/pegasus-2.1
'http://pkgs.fedoraproject.org/cgit/tog-pegasus.git/plain/pegasus-2.14.1-ssl-include.patch')
source_i686=("${pkgver}_Linux-x86_MSM.tar.gz::http://docs.avagotech.com/docs-and-downloads/https:/avagodocs.s3.amazonaws.com:443/docs-and-downloads/https:/avagodocs.s3.amazonaws.com:443/docs-and-downloads/raid-controllers/raid-controllers-common-files/MSM_linux_x86_installer-${_pkgver}.tar.gz")
source_x86_64=("${pkgver}_Linux-x64_MSM.tar.gz::http://docs.avagotech.com/docs-and-downloads/https:/avagodocs.s3.amazonaws.com:443/docs-and-downloads/https:/avagodocs.s3.amazonaws.com:443/docs-and-downloads/raid-controllers/raid-controllers-common-files/MSM_linux_x64_installer-${_pkgver}.tar.gz")
-sha1sums=('c832eaf240f6dfba843c4937f7a935382d48b9be'
+sha1sums=('3e0e9a5b5bae72af361db01825242aefcfc3094a'
+ 'c832eaf240f6dfba843c4937f7a935382d48b9be'
'0e5d7b71435760e3ef7c1e132ba05145ccbd1268'
'79fbe24898030db50295a6254e7c4627e2b51b7c'
'e52a1be05599cd7e5ecf1085311c00c7e16e4b43'
diff --git a/lynx_script_for_download_pegasus b/lynx_script_for_download_pegasus
new file mode 100644
index 000000000000..7382aa8bc153
--- /dev/null
+++ b/lynx_script_for_download_pegasus
@@ -0,0 +1,7 @@
+key ^J
+key D
+key Down Arrow
+key ^J
+key ^J
+key q
+key y