summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2015-08-27 09:36:28 +0300
committerChristoph Gysin2015-08-27 09:36:28 +0300
commit82db7afd086fe1ff6df2e7bf8cfd1bd06b432fba (patch)
tree52334cf51a8532291d7caf7b75b2c6d3d3210290
downloadaur-lttng-modules-git.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
-rw-r--r--lttng-modules-git.install14
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0952ba71e98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lttng-modules-git
+ pkgdesc = Kernel Modules for LTTng
+ pkgver = 2.7.0.rc1.11.gc7d89a6
+ pkgrel = 1
+ url = http://lttng.org/
+ install = lttng-modules-git.install
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ license = GPL2
+ license = MIT
+ makedepends = linux-headers
+ makedepends = git
+ depends = linux>=2.6.38
+ provides = lttng-modules
+ conflicts = lttng-modules
+ source = git://git.lttng.org/lttng-modules.git
+ sha1sums = SKIP
+
+pkgname = lttng-modules-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..393c3496f57d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.tar.*
+/lttng-modules/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56dac0a2af4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Christian Babeux <christian.babeux@0x80.ca>
+
+pkgname=lttng-modules-git
+_gitname="lttng-modules"
+pkgver=2.7.0.rc1.11.gc7d89a6
+pkgrel=1
+pkgdesc="Kernel Modules for LTTng"
+arch=('i686' 'x86_64')
+url="http://lttng.org/"
+license=('LGPL2.1' 'GPL2' 'MIT')
+depends=('linux>=2.6.38')
+makedepends=('linux-headers' 'git')
+provides=('lttng-modules')
+conflicts=('lttng-modules')
+install=${pkgname}.install
+source=('git://git.lttng.org/lttng-modules.git')
+sha1sums=('SKIP')
+
+pkgver()
+{
+ cd ${_gitname}
+ git describe --always | sed 's/-/./g;s/^v//'
+}
+
+
+build()
+{
+ cd ${_gitname}
+ make
+}
+
+package()
+{
+ cd ${_gitname}
+ make modules_install INSTALL_MOD_PATH=${pkgdir}/usr
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/lttng-modules-git.install b/lttng-modules-git.install
new file mode 100644
index 000000000000..2b53dd5c51f3
--- /dev/null
+++ b/lttng-modules-git.install
@@ -0,0 +1,14 @@
+post_install()
+{
+ depmod -a
+}
+
+post_upgrade()
+{
+ depmod -a
+}
+
+post_remove()
+{
+ depmod -a
+}