summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2015-08-27 09:36:28 +0300
committerChristoph Gysin2015-08-27 09:36:28 +0300
commit370fcf188a87b85e31b3eee933e1c8a2b1bf33d9 (patch)
tree5d3d0ed017c4cc85f1e0537fb4c97aeb78094e0b
downloadaur-370fcf188a87b85e31b3eee933e1c8a2b1bf33d9.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD38
-rw-r--r--lttng-tools-gcc51.patch105
4 files changed, 171 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c07cf088e7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = lttng-tools
+ pkgdesc = Trace control client for LTTng
+ pkgver = 2.6.0
+ pkgrel = 1
+ url = http://lttng.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ depends = popt
+ depends = liburcu>=0.7.2
+ depends = lttng-ust
+ depends = linux>=2.6.27
+ depends = libxml2>=2.7.6
+ optdepends = lttng-modules: kernel tracing support
+ optdepends = babeltrace: trace viewing
+ provides = lttng
+ options = !libtool
+ source = http://lttng.org/files/lttng-tools/lttng-tools-2.6.0.tar.bz2
+ source = lttng-tools-gcc51.patch
+ sha1sums = cdcbcb527b665d4df409fd7a8013dba97566190a
+ sha1sums = fe1deab975f2a453b5abf3f173f57477fcb8ad45
+
+pkgname = lttng-tools
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3317ac6609e8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg/
+/src/
+/*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..184049f00c3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Christian Babeux <christian.babeux@0x80.ca>
+# Contributor: Manuel Mendez <mmendez534 at gmail dot com>
+
+pkgname=lttng-tools
+pkgver=2.6.0
+pkgrel=1
+pkgdesc="Trace control client for LTTng"
+arch=('i686' 'x86_64')
+url="http://lttng.org/"
+license=('GPL2' 'LGPL2.1')
+provides=('lttng')
+source=(http://lttng.org/files/$pkgname/$pkgname-$pkgver.tar.bz2
+ ${pkgname}-gcc51.patch)
+depends=('popt' 'liburcu>=0.7.2' 'lttng-ust' 'linux>=2.6.27' 'libxml2>=2.7.6')
+optdepends=('lttng-modules: kernel tracing support' 'babeltrace: trace viewing')
+options=('!libtool')
+sha1sums=('cdcbcb527b665d4df409fd7a8013dba97566190a'
+ 'fe1deab975f2a453b5abf3f173f57477fcb8ad45')
+
+
+prepare()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np1 -i ../${pkgname}-gcc51.patch
+}
+
+build()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make install DESTDIR=${pkgdir}
+}
diff --git a/lttng-tools-gcc51.patch b/lttng-tools-gcc51.patch
new file mode 100644
index 000000000000..436169aa995a
--- /dev/null
+++ b/lttng-tools-gcc51.patch
@@ -0,0 +1,105 @@
+commit 96ffaa0c61089296dd5c9dd07810f32f97931fc8
+Author: Jérémie Galarneau <jeremie.galarneau@efficios.com>
+Date: Fri May 22 12:55:57 2015 -0400
+
+ Clean-up: Remove ifdef-ed out function:entry feature
+
+ Signed-off-by: Jérémie Galarneau <jeremie.galarneau@efficios.com>
+
+diff --git a/src/bin/lttng/commands/enable_events.c b/src/bin/lttng/commands/enable_events.c
+index ab32994..f1d0458 100644
+--- a/src/bin/lttng/commands/enable_events.c
++++ b/src/bin/lttng/commands/enable_events.c
+@@ -52,22 +52,15 @@ static int opt_python;
+ static int opt_enable_all;
+ static char *opt_probe;
+ static char *opt_function;
+-static char *opt_function_entry_symbol;
+ static char *opt_channel_name;
+ static char *opt_filter;
+ static char *opt_exclude;
+-#if 0
+-/* Not implemented yet */
+-static char *opt_cmd_name;
+-static pid_t opt_pid;
+-#endif
+
+ enum {
+ OPT_HELP = 1,
+ OPT_TRACEPOINT,
+ OPT_PROBE,
+ OPT_FUNCTION,
+- OPT_FUNCTION_ENTRY,
+ OPT_SYSCALL,
+ OPT_USERSPACE,
+ OPT_LOGLEVEL,
+@@ -94,13 +87,6 @@ static struct poptOption long_options[] = {
+ {"tracepoint", 0, POPT_ARG_NONE, 0, OPT_TRACEPOINT, 0, 0},
+ {"probe", 0, POPT_ARG_STRING, &opt_probe, OPT_PROBE, 0, 0},
+ {"function", 0, POPT_ARG_STRING, &opt_function, OPT_FUNCTION, 0, 0},
+-#if 0
+- /*
+- * Currently removed from lttng kernel tracer. Removed from
+- * lttng UI to discourage its use.
+- */
+- {"function:entry", 0, POPT_ARG_STRING, &opt_function_entry_symbol, OPT_FUNCTION_ENTRY, 0, 0},
+-#endif
+ {"syscall", 0, POPT_ARG_NONE, 0, OPT_SYSCALL, 0, 0},
+ {"loglevel", 0, POPT_ARG_STRING, 0, OPT_LOGLEVEL, 0, 0},
+ {"loglevel-only", 0, POPT_ARG_STRING, 0, OPT_LOGLEVEL_ONLY, 0, 0},
+@@ -144,10 +130,6 @@ static void usage(FILE *ofp)
+ fprintf(ofp, " Dynamic function entry/return probe.\n");
+ fprintf(ofp, " Addr and offset can be octal (0NNN...),\n");
+ fprintf(ofp, " decimal (NNN...) or hexadecimal (0xNNN...)\n");
+-#if 0
+- fprintf(ofp, " --function:entry symbol\n");
+- fprintf(ofp, " Function tracer event\n");
+-#endif
+ fprintf(ofp, " --syscall System call event\n");
+ fprintf(ofp, "\n");
+ fprintf(ofp, " --loglevel name\n");
+@@ -1053,11 +1035,6 @@ static int enable_events(char *session_name)
+ goto error;
+ }
+ break;
+- case LTTNG_EVENT_FUNCTION_ENTRY:
+- strncpy(ev.attr.ftrace.symbol_name, opt_function_entry_symbol,
+- LTTNG_SYMBOL_NAME_LEN);
+- ev.attr.ftrace.symbol_name[LTTNG_SYMBOL_NAME_LEN - 1] = '\0';
+- break;
+ case LTTNG_EVENT_SYSCALL:
+ ev.type = LTTNG_EVENT_SYSCALL;
+ break;
+@@ -1069,14 +1046,6 @@ static int enable_events(char *session_name)
+ /* kernel loglevels not implemented */
+ ev.loglevel_type = LTTNG_EVENT_LOGLEVEL_ALL;
+ } else if (opt_userspace) { /* User-space tracer action */
+-#if 0
+- if (opt_cmd_name != NULL || opt_pid) {
+- MSG("Only supporting tracing all UST processes (-u) for now.");
+- ret = CMD_UNDEFINED;
+- goto error;
+- }
+-#endif
+-
+ DBG("Enabling UST event %s for channel %s, loglevel %s", event_name,
+ print_channel_name(channel_name), opt_loglevel ? : "<all>");
+
+@@ -1091,7 +1060,6 @@ static int enable_events(char *session_name)
+ break;
+ case LTTNG_EVENT_PROBE:
+ case LTTNG_EVENT_FUNCTION:
+- case LTTNG_EVENT_FUNCTION_ENTRY:
+ case LTTNG_EVENT_SYSCALL:
+ default:
+ ERR("Event type not available for user-space tracing");
+@@ -1398,9 +1366,6 @@ int cmd_enable_events(int argc, const char **argv)
+ case OPT_FUNCTION:
+ opt_event_type = LTTNG_EVENT_FUNCTION;
+ break;
+- case OPT_FUNCTION_ENTRY:
+- opt_event_type = LTTNG_EVENT_FUNCTION_ENTRY;
+- break;
+ case OPT_SYSCALL:
+ opt_event_type = LTTNG_EVENT_SYSCALL;
+ break;