summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2024-04-01 14:49:18 +0300
committerCaleb Maclennan2024-04-01 14:49:18 +0300
commit166cd2890c7788cb1bfa8e5b1a462c8f55cefda8 (patch)
tree16ec50d67cd06b98a9db4b8a8a9d643f03e57691
parenta4e15bf32f73bda613be25b478222e39de9269f4 (diff)
downloadaur-lua-copas.tar.gz
upgpkg: lua-copas 4.7.0-6
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD12
2 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e2375372a1c..4b8ab6a778d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lua-copas
pkgdesc = A dispatcher based on coroutines that can be used by TCP/IP servers
pkgver = 4.7.0
- pkgrel = 5
+ pkgrel = 6
url = https://lunarmodules.github.io/copas
arch = x86_64
arch = i686
@@ -15,10 +15,30 @@ pkgbase = lua-copas
sha256sums = 54c16a5f56ff32f3a6c9410f5927c33156c81fde035772e5adc6404565ed3d3a
pkgname = lua-copas
+ depends = lua
+ depends = lua-binaryheap
+ depends = lua-socket
+ depends = lua-timerwheel
+ optdepends = lua-sec: secure sockets support
pkgname = lua53-copas
+ depends = lua53
+ depends = lua53-binaryheap
+ depends = lua53-socket
+ depends = lua53-timerwheel
+ optdepends = lua53-sec: secure sockets support
pkgname = lua52-copas
+ depends = lua52
+ depends = lua52-binaryheap
+ depends = lua52-socket
+ depends = lua52-timerwheel
+ optdepends = lua52-sec: secure sockets support
pkgname = lua51-copas
+ depends = lua51
+ depends = lua51-binaryheap
+ depends = lua51-socket
+ depends = lua51-timerwheel
depends = lua51-coxpcall
+ optdepends = lua51-sec: secure sockets support
diff --git a/PKGBUILD b/PKGBUILD
index 1339df2847b5..4e351f0ef4df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _rockname=copas
pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=4.7.0
_rockrel=1
-pkgrel=5
+pkgrel=6
pkgdesc='A dispatcher based on coroutines that can be used by TCP/IP servers'
arch=(x86_64 i686)
url="https://lunarmodules.github.io/$_rockname"
@@ -24,8 +24,6 @@ source=("$_url/archive/$pkgver/$_archive.tar.gz")
sha256sums=('54c16a5f56ff32f3a6c9410f5927c33156c81fde035772e5adc6404565ed3d3a')
_package() {
- depends+=("${pkgname%%-*}" "${_luadeps[@]/#/${pkgname%%-*}-}")
- optdepends+=("${pkgname%%-*}-sec: secure sockets support")
cd "$_archive"
luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
make --deps-mode=none --no-manifest \
@@ -36,18 +34,26 @@ _package() {
}
package_lua-copas() {
+ depends+=("${pkgname%%-*}" "${_luadeps[@]/#/${pkgname%%-*}-}")
+ optdepends+=("${pkgname%%-*}-sec: secure sockets support")
_package 5.4
}
package_lua53-copas() {
+ depends+=("${pkgname%%-*}" "${_luadeps[@]/#/${pkgname%%-*}-}")
+ optdepends+=("${pkgname%%-*}-sec: secure sockets support")
_package 5.3
}
package_lua52-copas() {
+ depends+=("${pkgname%%-*}" "${_luadeps[@]/#/${pkgname%%-*}-}")
+ optdepends+=("${pkgname%%-*}-sec: secure sockets support")
_package 5.2
}
package_lua51-copas() {
+ depends+=("${pkgname%%-*}" "${_luadeps[@]/#/${pkgname%%-*}-}")
+ optdepends+=("${pkgname%%-*}-sec: secure sockets support")
depends+=(lua51-coxpcall)
_package 5.1
}