summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAanok2018-08-07 12:55:51 +0200
committerAanok2018-08-07 12:55:51 +0200
commit10e2a92e5853018077b57a645367e0afe3be77e1 (patch)
tree899fe62efcb2e78bfa6eec1ed7e851074be12e10
downloadaur-lua-html-entities-git.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..162fa1b4e8ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lua-html-entities-git
+ pkgdesc = Module for Lua, decoding html entities
+ pkgver = 1.3.0.r2.880a6bd
+ pkgrel = 1
+ url = https://github.com/TiagoDanin/htmlEntities-for-lua
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = lua
+ provides = lua-html-entities
+ source = git+https://github.com/TiagoDanin/htmlEntities-for-lua.git
+ md5sums = SKIP
+
+pkgname = lua-html-entities-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ebaba789c19f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Aanok <aanok.aur@gmail.com>
+pkgname=lua-html-entities-git
+pkgver=1.3.0.r2.880a6bd
+pkgrel=1
+pkgdesc="Module for Lua, decoding html entities"
+arch=('x86_64')
+url="https://github.com/TiagoDanin/htmlEntities-for-lua"
+license=('MIT')
+depends=('lua')
+makedepends=('git')
+provides=("${pkgname%-git}")
+source=('git+https://github.com/TiagoDanin/htmlEntities-for-lua.git')
+md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/htmlEntities-for-lua"
+
+ # Git, unannotated tags available
+ printf "%s" "$(git describe --long --tags | sed 's/v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+package() {
+ cd "$srcdir/htmlEntities-for-lua"
+
+ install -D -m644 "src/htmlEntities.lua" "${pkgdir}/usr/share/lua/5.3/htmlEntities.lua"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE.md"
+} \ No newline at end of file