summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2019-06-27 11:34:43 +0300
committerCaleb Maclennan2019-06-27 11:34:43 +0300
commitb1f9932fff3e7209289e54df28b075c9f88bb6e4 (patch)
tree423f6148193d2405def49ea91978a4f785eaf4ef
downloadaur-b1f9932fff3e7209289e54df28b075c9f88bb6e4.tar.gz
Add initial PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09068949c175
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lua-path
+ pkgdesc = File system path manipulation library
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/moteus/lua-path
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = luarocks
+ depends = lua
+ source = https://luarocks.org/lua-path-0.3.1-1.rockspec
+ sha256sums = bde578f79d032ccda47da4d73e0633281b3e0497c54b87a8667acfc477491e50
+
+pkgname = lua-path
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0ca50ff4dd97
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!./.SRCINFO
+!./.gitignore
+!./PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abd709817064
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=lua-path
+pkgver=0.3.1
+_rockname=lua-path
+_rockrel=1
+pkgrel=1
+pkgdesc="File system path manipulation library"
+arch=('i686' 'x86_64')
+url="https://github.com/moteus/lua-path"
+license=('MIT')
+depends=('lua')
+makedepends=('luarocks')
+conflicts=()
+source=("https://luarocks.org/$_rockname-$pkgver-$_rockrel.rockspec")
+sha256sums=('bde578f79d032ccda47da4d73e0633281b3e0497c54b87a8667acfc477491e50')
+
+package() {
+ luarocks --tree="$pkgdir/usr" install --deps-mode=none "$_rockname-$pkgver-$_rockrel.rockspec"
+ find "$pkgdir/usr" -name manifest -delete
+}