summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-05-07 19:54:01 +0300
committerCaleb Maclennan2022-05-07 19:54:01 +0300
commitc9b8a731a66713c6555d0eb6a8c90f83e0bbda9b (patch)
tree14d77ad67497dd58e838ef004fe6e59ca45bcc0c
parent8e8f52ed5dab5be4282f662f830fe4c90c10d5f2 (diff)
downloadaur-c9b8a731a66713c6555d0eb6a8c90f83e0bbda9b.tar.gz
upgpkg: lua-path 0.3.1-5
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD41
2 files changed, 26 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ff5119bc140..2f19abd9d52f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,23 @@
pkgbase = lua-path
pkgdesc = File system path manipulation library
pkgver = 0.3.1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/moteus/lua-path
arch = i686
arch = x86_64
license = MIT
makedepends = lua
- makedepends = lua53
- makedepends = lua52
makedepends = lua51
+ makedepends = lua52
+ makedepends = lua53
makedepends = luarocks
- source = path-0.3.1.tar.gz::https://github.com/moteus/lua-path/archive/v0.3.1.tar.gz
+ source = https://github.com/moteus/lua-path/archive/v0.3.1/lua-path-0.3.1.tar.gz
sha256sums = f7419d9012cb5005a9adbc6e567fee44832a42a73532451336de066ff2ebcce5
pkgname = lua-path
- depends = lua
pkgname = lua53-path
- depends = lua53
pkgname = lua52-path
- depends = lua52
pkgname = lua51-path
- depends = lua51
-
diff --git a/PKGBUILD b/PKGBUILD
index 9e807ce4fd92..2ef2889467b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,37 +5,40 @@ pkgbase="lua-$_rockname"
pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=0.3.1
_rockrel=1
-pkgrel=4
+pkgrel=5
pkgdesc='File system path manipulation library'
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
url="https://github.com/moteus/$pkgbase"
-license=('MIT')
-makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
-source=("$_rockname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+license=(MIT)
+makedepends=(lua
+ lua51
+ lua52
+ lua53
+ luarocks)
+_archive="$pkgbase-$pkgver"
+source=("$url/archive/v$pkgver/$_archive.tar.gz")
sha256sums=('f7419d9012cb5005a9adbc6e567fee44832a42a73532451336de066ff2ebcce5')
-_package_helper() {
- cd "$pkgbase-$pkgver"
- luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
- make --deps-mode=none --no-manifest "rockspecs/$pkgbase-$pkgver-$_rockrel.rockspec"
+_package() {
+ cd "$_archive"
+ depends=("${pkgname%-*}")
+ luarocks --lua-version "$1" --tree "$pkgdir/usr/" \
+ make --deps-mode none --no-manifest -- "rockspecs/$_archive-$_rockrel.rockspec"
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENCE.txt
}
package_lua-path() {
- depends+=('lua')
- _package_helper 5.4
+ _package 5.4
}
-package_lua53-path() {
- depends+=('lua53')
- _package_helper 5.3
+package_lua51-path() {
+ _package 5.1
}
package_lua52-path() {
- depends+=('lua52')
- _package_helper 5.2
+ _package 5.2
}
-package_lua51-path() {
- depends+=('lua51')
- _package_helper 5.1
+package_lua53-path() {
+ _package 5.3
}