summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Berquist2018-05-11 21:47:04 -0400
committerEric Berquist2018-05-11 21:47:04 -0400
commit2e92931a8bd5464a088f515fa65a0a3b6b7fa2e7 (patch)
treede80ac4cca255a5b820fd21a7c333a641069c3b0
parent390f7c5ef09a9002d44211eb2bbbc6daa8888a40 (diff)
downloadaur-2e92931a8bd5464a088f515fa65a0a3b6b7fa2e7.tar.gz
The build system has changed.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD37
2 files changed, 15 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd6f6d288eda..91415549e37b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Sep 16 20:37:10 UTC 2016
+# Sat May 12 01:41:31 UTC 2018
pkgbase = lua-posix-git
pkgdesc = POSIX library for Lua
- pkgver = 33.4.0.11.g3ab67b5
- pkgrel = 2
+ pkgver = 33.4.0.136.g69c1799
+ pkgrel = 1
url = https://github.com/luaposix/luaposix
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index a55dd0a84f8f..6e1221e47ccf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,10 @@
_pkgname=lua-posix
pkgname="${_pkgname}-git"
-pkgver=33.4.0.11.g3ab67b5
-pkgrel=2
+pkgver=33.4.0.136.g69c1799
+pkgrel=1
pkgdesc='POSIX library for Lua'
-arch=('x86_64' 'i686')
+arch=('x86_64')
url='https://github.com/luaposix/luaposix'
license=('MIT')
conflicts=("${_pkgname}")
@@ -23,35 +23,22 @@ source=("${_pkgname}::git://github.com/luaposix/luaposix.git")
md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
git describe --always | sed 's+^v++' | sed 's+-+.+g'
}
-prepare() {
- cd "${_pkgname}"
- sed -i '19,20d' bootstrap.conf
-}
-
build() {
- cd "${_pkgname}"
-
- luaver=$(/usr/bin/lua -v | cut -d " " -f 2 | cut -d "." -f 1,2)
-
- ./bootstrap
-
- ./configure \
- LUA=/usr/bin/lua \
- --prefix=/usr \
- --libdir=/usr/lib/lua/${luaver} \
- --datadir=/usr/share/lua/${luaver} \
- --docdir=/usr/share/doc/lua-posix
+ cd "${srcdir}/${_pkgname}"
- make
+ ./build-aux/luke \
+ all
}
package() {
- cd "${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ ./build-aux/luke \
+ PREFIX="${pkgdir}"/usr \
+ install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}