summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiachen Yang2015-08-10 19:26:02 +0900
committerJiachen Yang2015-08-10 19:26:02 +0900
commit7aeb4dd8e48179b8d3cf692a2b41ec04d48d98a2 (patch)
tree346f81ad1bde0d3e48085eda382adedbe86b86b4
downloadaur-lua51-logging.tar.gz
takeover lua51-logging
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD31
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3175876d2e5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lua51-logging
+ pkgdesc = Simple API to use logging features in Lua
+ pkgver = 1.1.4
+ pkgrel = 2
+ url = http://www.keplerproject.org/lualogging/
+ arch = any
+ license = MIT
+ depends = lua51
+ conflicts = lualogging
+ replaces = lualogging
+ source = http://luaforge.net/frs/download.php/2693/lualogging-1.1.4.tar.gz
+ source = LICENSE
+ md5sums = 72a8622748a525f5fb8ed23278326f80
+ md5sums = c2a5289bdfe3702fd77b365a48251c08
+
+pkgname = lua51-logging
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8ca56ecd2e9a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+Copyright © 2004-2007 The Kepler Project.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd25c1232aa6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: farseerfc <farseerfc@archlinuxcn.org>
+# Contributor: Lucky <archlinux@builds.lucky.li>
+# Contributor: Chris Brannon <cmbrannon79@gmail.com>
+# Contributor: Paulo Matias <matiasΘarchlinux-br·org>
+# Contributor: Anders Bergh <anders1@gmail.com>
+
+pkgname=lua51-logging
+pkgver=1.1.4
+pkgrel=2
+pkgdesc="Simple API to use logging features in Lua"
+url="http://www.keplerproject.org/lualogging/"
+license=("MIT")
+arch=("any")
+depends=("lua51")
+replaces=("lualogging")
+conflicts=("lualogging")
+source=("http://luaforge.net/frs/download.php/2693/lualogging-${pkgver}.tar.gz"
+ "LICENSE")
+md5sums=("72a8622748a525f5fb8ed23278326f80"
+ "c2a5289bdfe3702fd77b365a48251c08")
+
+package() {
+ cd "lualogging-${pkgver}/src"
+
+ install -dm755 "${pkgdir}/usr/share/lua/5.1/logging"
+ cp logging/*.lua "${pkgdir}/usr/share/lua/5.1/logging"
+ mv "${pkgdir}/usr/share/lua/5.1/logging/logging.lua" "${pkgdir}/usr/share/lua/5.1"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: