summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2024-03-15 18:18:27 +0100
committerMarco Pompili2024-03-15 18:18:27 +0100
commitc53618d6d3241247829fcc9da0bd2ec8db042401 (patch)
treeb296d114fe2e81f705447867ab34018a02c5447d
parent403e1186a18b0acd049cf9db3f7f3220ed05e122 (diff)
downloadaur-luabind.tar.gz
dependency update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d68c0c3581f5..8e3e24daed2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Thu Nov 24 01:47:42 UTC 2016
pkgbase = luabind
pkgdesc = A library that helps you create bindings between C++ and Lua
pkgver = 0.9.1
@@ -9,9 +7,9 @@ pkgbase = luabind
arch = x86_64
license = MIT
makedepends = unzip
- makedepends = boost
- makedepends = boost-build
- depends = lua
+ makedepends = lua51
+ makedepends = boost>=1.62
+ depends = lua51
depends = gcc-libs
source = http://downloads.sourceforge.net/luabind/luabind-0.9.1.tar.gz
source = luabind_boost.patch
@@ -21,4 +19,3 @@ pkgbase = luabind
sha256sums = 4d88455c7a1d5fe2356da07b1d008bdcfc82492a47dae8adefeb588939d3d714
pkgname = luabind
-
diff --git a/PKGBUILD b/PKGBUILD
index 66d3e05e390f..20ffe149a532 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# $Id: PKGBUILD 78820 2012-10-25 06:47:28Z foutrelis $
# Maintainer: Marco Pompili <marcs.pompili@gmail.com>
-# Maintainer: Jakob Gruber <jakob.gruber@gmail.com>
-# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Jakob Gruber <jakob.gruber@gmail.com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: rayte <rabyte.at.gmail.dot.com>
pkgname=luabind
@@ -11,12 +11,11 @@ pkgdesc="A library that helps you create bindings between C++ and Lua"
arch=('i686' 'x86_64')
url="http://www.rasterbar.com/products/luabind.html"
license=('MIT')
-makedepends=('unzip' 'boost' 'boost-build')
-depends=('lua' 'gcc-libs')
+makedepends=('unzip' 'lua51' 'boost>=1.62')
+depends=('lua51' 'gcc-libs')
source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
"luabind_boost.patch"
- "boost_1.57.patch")
-
+ "boost_1.57.patch")
sha256sums=('80de5e04918678dd8e6dac3b22a34b3247f74bf744c719bae21faaa49649aaae'
'010026c1446b276e9e04f11851aca90c5172841cf421c3a31aef4ab442c80d7e'
'4d88455c7a1d5fe2356da07b1d008bdcfc82492a47dae8adefeb588939d3d714')
@@ -28,7 +27,7 @@ build() {
patch -Np1 -i ${srcdir}/boost_1.57.patch
# build luabind
- # export LUA_PATH=/usr/include/lua51
+ export LUA_PATH=/usr/include/lua51
# export LUA_PATH=/usr/include/lua52
b2 release --prefix=${pkgdir}/usr/ link=static,shared
}
@@ -39,6 +38,7 @@ package() {
b2 release --prefix=${pkgdir}/usr/ link=static,shared install
# copy license
- install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE \
- ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 \
+ ${srcdir}/${pkgname}-${pkgver}/LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}