summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-18 16:16:17 +0100
committerAlexander F. Rødseth2019-03-18 16:16:17 +0100
commitdd957e16c5c6f0ef73cde586067d71314b2425cd (patch)
tree1ebd822c26d455fbfbc0e199d1cb1433238b3b2d
downloadaur-ludwig-example.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--LICENSE3
-rw-r--r--PKGBUILD29
-rw-r--r--ludwig-example5
-rw-r--r--model_definition.yaml1
5 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1657d78741bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Mar 18 15:16:02 UTC 2019
+pkgbase = ludwig-example
+ pkgdesc = Example for training deep learning models with Ludwig
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://archive.ics.uci.edu/ml/datasets/Reuters-21578+Text+Categorization+Collection
+ arch = any
+ license = custom
+ depends = python-ludwig
+ source = http://boston.lti.cs.cmu.edu/classes/95-865-K/HW/HW2/reuters-allcats-6.zip
+ source = model_definition.yaml
+ source = ludwig-example
+ source = LICENSE
+ sha256sums = 304ae223f9ca35f7ce9066c9d31558c06ed5c72cd91faa885f82b928b2aa6f34
+ sha256sums = 27f15371a678d474594b4b9b241c7a6744eed8b3618a91e1934aeed03d7da9a6
+ sha256sums = bebaec0bc5d12a63dbfe49f738260297b0332e1a799166dcb049ba01d7dcc923
+ sha256sums = c20059f271d10ff8bada6fda7e3af47cb5a0954b60075654e5f7a97f25b52186
+
+pkgname = ludwig-example
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..93589cd8aaea
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,3 @@
+The copyright for the text of newswire articles and Reuters annotations in the Reuters-21578 collection resides with Reuters Ltd. Reuters Ltd. and Carnegie Group, Inc. have agreed to allow the free distribution of this data *for research purposes only*.
+
+http://archive.ics.uci.edu/ml/datasets/Reuters-21578+Text+Categorization+Collection
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d978d17b5da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=ludwig-example
+pkgver=1.0
+pkgrel=1
+pkgdesc='Example for training deep learning models with Ludwig'
+arch=(any)
+url='http://archive.ics.uci.edu/ml/datasets/Reuters-21578+Text+Categorization+Collection'
+license=(custom)
+depends=(python-ludwig)
+source=('http://boston.lti.cs.cmu.edu/classes/95-865-K/HW/HW2/reuters-allcats-6.zip'
+ model_definition.yaml
+ ludwig-example
+ LICENSE)
+sha256sums=('304ae223f9ca35f7ce9066c9d31558c06ed5c72cd91faa885f82b928b2aa6f34'
+ '27f15371a678d474594b4b9b241c7a6744eed8b3618a91e1934aeed03d7da9a6'
+ 'bebaec0bc5d12a63dbfe49f738260297b0332e1a799166dcb049ba01d7dcc923'
+ 'c20059f271d10ff8bada6fda7e3af47cb5a0954b60075654e5f7a97f25b52186')
+
+package() {
+ install -Dm644 reuters-allcats.csv "$pkgdir/usr/share/$pkgname/reuters-allcats.csv"
+ install -Dm755 model_definition.yaml "$pkgdir/usr/share/$pkgname/model_definition.yaml"
+ chmod a+w "$pkgdir/usr/share/$pkgname"
+
+ install -Dm755 ludwig-example "$pkgdir/usr/bin/ludwig-example"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/ludwig-example b/ludwig-example
new file mode 100644
index 000000000000..e619def8a006
--- /dev/null
+++ b/ludwig-example
@@ -0,0 +1,5 @@
+#!/bin/sh
+cd /tmp
+ludwig experiment \
+ --data_csv /usr/share/ludwig-example/reuters-allcats.csv \
+ --model_definition_file /usr/share/ludwig-example/model_definition.yaml
diff --git a/model_definition.yaml b/model_definition.yaml
new file mode 100644
index 000000000000..73091ff0636a
--- /dev/null
+++ b/model_definition.yaml
@@ -0,0 +1 @@
+{input_features: [{name: text, type: text}], output_features: [{name: class, type: category}]}