summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2022-01-31 09:45:52 -0500
committerCorey Hinshaw2022-01-31 09:45:52 -0500
commitd21df45f8fa8c7bd30e7d1b1de537cb2839683e4 (patch)
treea35fb2c5a25cbdc57f18946b7abe3e0812f16e77
parentc0cd171cc8b9b318e719ba02666003052987d5a5 (diff)
downloadaur-d21df45f8fa8c7bd30e7d1b1de537cb2839683e4.tar.gz
Update hook to use Type = Path
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD4
-rw-r--r--luks-tpm2.hook2
4 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f89f3f0f0fea..84d7de698a54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = luks-tpm2
pkgdesc = Utility to manage LUKS keys sealed by a TPM 2.0
pkgver = 2.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/electrickite/luks-tpm2
install = luks-tpm2.install
arch = any
@@ -17,7 +17,6 @@ pkgbase = luks-tpm2
source = https://github.com/electrickite/luks-tpm2/archive/2.1.1.tar.gz
source = luks-tpm2.hook
sha1sums = 3c446f7a8796abc9552c7402c03343f7a52e20f9
- sha1sums = 6156622b538d8f78d2930bc85e91d3bfee5ebfb6
+ sha1sums = e4b308b4e789d0ca9f1659b22ad0cd9193749558
pkgname = luks-tpm2
-
diff --git a/.gitignore b/.gitignore
index 0cced017d91a..9fae8a7b4224 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.xz
*.tar.gz
+*.tar.zst
/pkg
/src
diff --git a/PKGBUILD b/PKGBUILD
index 136d6ee95cf5..0de3a7ed3984 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=luks-tpm2
pkgver=2.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Utility to manage LUKS keys sealed by a TPM 2.0"
arch=('any')
url="https://github.com/electrickite/${pkgname}"
@@ -20,7 +20,7 @@ optdepends=('tpm_futurepcr: To pre-compute kernel PCR values')
source=("https://github.com/electrickite/${pkgname}/archive/${pkgver}.tar.gz"
"${pkgname}.hook")
sha1sums=('3c446f7a8796abc9552c7402c03343f7a52e20f9'
- '6156622b538d8f78d2930bc85e91d3bfee5ebfb6')
+ 'e4b308b4e789d0ca9f1659b22ad0cd9193749558')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/luks-tpm2.hook b/luks-tpm2.hook
index 883519a5db1e..5729678d20ed 100644
--- a/luks-tpm2.hook
+++ b/luks-tpm2.hook
@@ -2,7 +2,7 @@
Operation = Install
Operation = Upgrade
Operation = Remove
-Type = File
+Type = Path
Target = boot/vmlinuz-*
Target = boot/intel-ucode.img
Target = usr/lib/initcpio/*