summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2016-02-07 15:08:25 +0100
committerChristopher Arndt2016-02-07 15:08:25 +0100
commit72e8644ffff9429f63bd60662ed82557387e4582 (patch)
treea078c47c13533bcf394f43b90f45a9994eab5f9e
downloadaur-lv2file.tar.gz
Add new package lv2file
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD30
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b09838690e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Feb 7 14:05:59 UTC 2016
+pkgbase = lv2file
+ pkgdesc = A command line program to process audio files with LV2 plugins
+ pkgver = 0.84
+ pkgrel = 1
+ url = https://github.com/jeremysalwen/lv2file
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL3
+ depends = argtable
+ depends = libsndfile
+ depends = lilv
+ source = https://github.com/jeremysalwen/lv2file/archive/upstream/0.84.tar.gz
+ source = https://raw.githubusercontent.com/jeremysalwen/lv2file/master/debian/lv2file.1
+ md5sums = 259719c6291d4b774db3e3a485e12d18
+ md5sums = f6b06337c3a87051d47d533c2b88addd
+
+pkgname = lv2file
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4402d08e99b1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg/
+src/
+.AURINFO
+lv2file-*.tar.xz
+lv2file-*.src.tar.gz
+*.tar.gz
+lv2file.1
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe412871dbed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+pkgname=lv2file
+pkgver=0.84
+pkgrel=1
+pkgdesc="A command line program to process audio files with LV2 plugins"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/jeremysalwen/lv2file"
+license=('GPL3')
+depends=('argtable' 'libsndfile' 'lilv')
+source=("https://github.com/jeremysalwen/lv2file/archive/upstream/0.84.tar.gz"
+ "https://raw.githubusercontent.com/jeremysalwen/lv2file/master/debian/lv2file.1")
+md5sums=('259719c6291d4b774db3e3a485e12d18'
+ 'f6b06337c3a87051d47d533c2b88addd')
+
+build() {
+ cd "${srcdir}/${pkgname}-upstream-${pkgver}"
+
+ make all
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-upstream-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm 644 "$srcdir/${pkgname}.1" \
+ "$pkgdir/usr/share/man/man1/${pkgname}.1"
+}
+
+# vim:set ts=2 sw=2 et: