summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892020-07-30 23:05:24 +0200
committerPhoton892020-07-30 23:05:24 +0200
commite986d4c7106e1a9cf9f62d7beef12784aafdc7d7 (patch)
tree1714282ef7118d613f62519fed62883d28b3e5bd
parent301c4c6760bf3f03798a20a2a324454b35513027 (diff)
downloadaur-lxpanel-multiload-ng-plugin-gtk2.tar.gz
Silent update: Added patch to fix build errors
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--build-fix.patch24
3 files changed, 30 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee47f39e5471..fef1e448623a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,9 @@ pkgbase = lxpanel-multiload-ng-plugin-gtk2
conflicts = lxpanel-multiload-ng-plugin-gtk3-git
replaces = lxpanel-multiload-ng-applet-gtk2
source = https://github.com/udda/multiload-ng/archive/v1.5.2.tar.gz
+ source = build-fix.patch
md5sums = bdb9344d696324bd4db04a8bce6d7ec0
+ md5sums = b474387e4532bdd6a639f721a51d2587
pkgname = lxpanel-multiload-ng-plugin-gtk2
diff --git a/PKGBUILD b/PKGBUILD
index 0e561f280447..acb7b4bb8e8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,9 @@ conflicts=('lxpanel-multiload-ng-plugin-gtk3' 'lxpanel-multiload-ng-plugin-gtk2-
replaces=('lxpanel-multiload-ng-applet-gtk2')
-source=("https://github.com/udda/multiload-ng/archive/v$pkgver.tar.gz")
-md5sums=('bdb9344d696324bd4db04a8bce6d7ec0')
+source=("https://github.com/udda/multiload-ng/archive/v$pkgver.tar.gz" "build-fix.patch")
+md5sums=('bdb9344d696324bd4db04a8bce6d7ec0'
+'b474387e4532bdd6a639f721a51d2587')
arch=('i686' 'x86_64')
url='https://udda.github.io/multiload-ng/'
@@ -24,6 +25,7 @@ license=('GPL2')
build() {
cd "multiload-ng-$pkgver"
+ patch -p1 -i $srcdir/build-fix.patch
./autogen.sh
./configure --prefix=/usr --with-gtk=2.0 --without-awn --without-indicator --with-lxpanel --without-mate --without-standalone --without-systray --without-xfce4
make
diff --git a/build-fix.patch b/build-fix.patch
new file mode 100644
index 000000000000..6e7f125bad49
--- /dev/null
+++ b/build-fix.patch
@@ -0,0 +1,24 @@
+diff -Naur a/common/multiload-config.c b/common/multiload-config.c
+--- a/common/multiload-config.c 2016-12-05 17:13:59.000000000 +0100
++++ b/common/multiload-config.c 2020-07-30 21:18:03.568945194 +0200
+@@ -26,6 +26,8 @@
+ #include "graph-data.h"
+ #include "multiload-config.h"
+
++GraphType graph_types[GRAPH_MAX];
++
+ guint multiload_config_get_num_colors(guint id)
+ {
+ g_assert_cmpuint (graph_types[id].num_colors, <=, MAX_COLORS);
+diff -Naur a/common/multiload-config.h b/common/multiload-config.h
+--- a/common/multiload-config.h 2016-12-05 17:13:59.000000000 +0100
++++ b/common/multiload-config.h 2020-07-30 21:18:21.685273529 +0200
+@@ -56,7 +56,7 @@
+
+
+ // global variable
+-GraphType graph_types[GRAPH_MAX];
++extern GraphType graph_types[GRAPH_MAX];
+
+
+ G_GNUC_INTERNAL guint