summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2024-04-24 15:27:37 +0200
committerPeter Mattern2024-04-25 11:28:14 +0200
commitdd102f0f0c319bdcbafb7be13663ec21925aa9af (patch)
tree4ec5450711a9dfd499a521452149fee7bc5aec5c
parent52804283757954442c2d17597dc1353b60e40f2b (diff)
downloadaur-lxqt-powermanagement-git.tar.gz
Miscellaneous updates
* upstream URL (homepage) * license string * dependencies * improve pkgver()
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f0caef0ff3f..8799f02a6bd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
pkgbase = lxqt-powermanagement-git
pkgdesc = LXQt power management daemon
- pkgver = 1.3.0.8.g93e1441
+ pkgver = 2.0.0
pkgrel = 1
- url = https://lxqt.org
+ url = https://lxqt-project.org
arch = i686
arch = x86_64
- license = GPL2
+ license = LGPL-2.1-only
makedepends = cmake
makedepends = git
- makedepends = qt5-tools
+ makedepends = qt6-tools
makedepends = lxqt-build-tools-git
+ depends = upower
+ depends = kidletime
+ depends = solid
+ depends = qt6-svg
depends = liblxqt-git
depends = lxqt-globalkeys-git
- depends = qt5-svg
- depends = qt5-x11extras
- depends = upower
- depends = kidletime5
- depends = solid5
depends = hicolor-icon-theme
- provides = lxqt-powermanagement=1.3.0.8.g93e1441
+ provides = lxqt-powermanagement=2.0.0
conflicts = lxqt-powermanagement
source = git+https://github.com/lxqt/lxqt-powermanagement.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f1e2b4cd6cc1..4ac028104134 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Jerome Leclanche <jerome@leclan.ch>
-# Co-Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Co-Maintainer: Peter Mattern <pmattern at arcor dot de>
+# Contributor: Jerome Leclanche <jerome@leclan.ch>
_pkgname=lxqt-powermanagement
pkgname=$_pkgname-git
-pkgver=1.3.0.8.g93e1441
+pkgver=2.0.0
pkgrel=1
pkgdesc="LXQt power management daemon"
arch=("i686" "x86_64")
-url="https://lxqt.org"
-license=("GPL2")
-depends=("liblxqt-git" "lxqt-globalkeys-git" "qt5-svg" "qt5-x11extras" "upower" "kidletime5" "solid5" "hicolor-icon-theme")
-makedepends=("cmake" "git" "qt5-tools" "lxqt-build-tools-git")
+url="https://lxqt-project.org"
+license=("LGPL-2.1-only")
+depends=('upower' 'kidletime' 'solid' 'qt6-svg' 'liblxqt-git' 'lxqt-globalkeys-git' 'hicolor-icon-theme')
+makedepends=('cmake' 'git' 'qt6-tools' 'lxqt-build-tools-git')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("git+https://github.com/lxqt/$_pkgname.git")
sha256sums=('SKIP')
-
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --always | sed "s/-/./g"
+ git describe --always | sed "s/-/.r/;s/-/./"
}
build() {