summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-01-10 16:29:22 -0500
committerCarlos Aznarán2024-01-10 16:29:22 -0500
commit7556df7c198744b288fa4ffe5d69c36607f41371 (patch)
treeab8e5373f31ff0ba2953b47e6ab16783c680e5c1
parent6a8254606bcd208e39408101ade24b2025097f55 (diff)
downloadaur-lyx.tar.gz
Made autoconf version constraint more flexible
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD21
3 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ea8b249e35e..91a56ed42a61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lyx
pkgdesc = An advanced WYSIWYM document processor & LaTeX front-end
pkgver = 2.3.7
- pkgrel = 2
+ pkgrel = 3
url = https://www.lyx.org
arch = x86_64
license = GPL
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index 012558421894..2d49ac39cb88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,31 @@
pkgname=lyx
pkgver=2.3.7
-pkgrel=2
+pkgrel=3
pkgdesc="An advanced WYSIWYM document processor & LaTeX front-end"
-arch=('x86_64')
-url="https://www.lyx.org"
-depends=('qt5-svg' 'texlive-basic' 'python' 'imagemagick' 'enchant' 'hunspell'
- 'libmythes' 'file' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('boost' 'bc')
+arch=(x86_64)
+url="https://www.${pkgname}.org"
+depends=(qt5-svg texlive-basic python imagemagick enchant hunspell
+ libmythes file hicolor-icon-theme desktop-file-utils)
+makedepends=(boost bc)
optdepends=('rcs: built-in version control system'
'texlive-latexextra: float wrap support'
'python: support for python scripts')
-license=('GPL')
+license=(GPL)
backup=('etc/lyx/lyxrc.dist')
options=('emptydirs' '!lto')
-source=(https://ftp.lip6.fr/pub/lyx/stable/${pkgver::4}x/lyx-${pkgver}-1.tar.gz{,.sig}
+source=(https://ftp.lip6.fr/pub/${pkgname}/stable/${pkgver::4}x/${pkgname}-${pkgver}-1.tar.gz{,.sig}
lyxrc.dist)
validpgpkeys=('FE66471B43559707AFDAD955DE7A44FAC7FB382D') # LyX Release Manager (Signing LyX tarballs and binaries) <sanda@lyx.org>
sha512sums=('e3d936127b43ebc0f62aa6179fbc9cd00610ad5c6fd8946c85f6963e4bf10140babdb961234d85dc1f4d56dfd16eb12810764701d6e8501e6864e3ce6e8d596d'
'SKIP'
'eef777cf6033a7b1e04700f33068b07309f8d5c6931c16927305dafb3a00fd46d4b536149349ab56b7455e7dea195c8889da2b6fbf9caa9e76bc0557f9358bc3')
+prepare() {
+ # Expand the automake compatibility version
+ sed -i 's/2.71/2.7\[1-9\]/' "${pkgname}-${pkgver}"/autogen.sh
+}
+
build() {
cd ${pkgname}-${pkgver}
./autogen.sh