summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Favre2015-06-26 07:57:09 +0200
committerBenoit Favre2015-06-26 07:57:09 +0200
commitb7e35e8906effebef3d0f7dea65fcf131711eadc (patch)
treef0d713f34c2cb2667a42e514158a9825ba3b3434
downloadaur-macaon.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d73a2716c146
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = macaon
+ pkgdesc = A natural language processing (NLP) toolchain that can work on ambiguous inputs (word lattices).
+ pkgver = 5.0.0
+ pkgrel = 1
+ url = http://macaon.lif.univ-mrs.fr/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glib2
+ depends = libxml2
+ depends = gfsm
+ source = http://macaon.lif.univ-mrs.fr//uploads/macaon/packages/sources/macaon-5.0.0.tar.gz
+ md5sums = e656b0a4fa3b51140b437ee9ef46f136
+
+pkgname = macaon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84dde7e41134
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Benoit Favre <benoit.favre@lif.univ-mrs.fr>
+pkgname=macaon
+pkgver=5.0.0
+pkgrel=1
+pkgdesc="A natural language processing (NLP) toolchain that can work on ambiguous inputs (word lattices)."
+arch=(i686 x86_64)
+url="http://macaon.lif.univ-mrs.fr/"
+license=('GPL')
+groups=()
+depends=(glib2 libxml2 gfsm)
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=($url/uploads/macaon/packages/sources/$pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums=(e656b0a4fa3b51140b437ee9ef46f136) #generate with 'makepkg -g'
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: