summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Melentyev2018-07-07 13:20:46 +0200
committerAndrey Melentyev2018-07-07 13:55:50 +0200
commit203317e55e58b154e4bade7c95bd12f6d94ce26f (patch)
treee11fc9eb64698cfa117bc9d1f18cc5c573a8eb1c
parent2eca4af8fed1bbe9b58f89e0e129c4d99ca58837 (diff)
downloadaur-203317e55e58b154e4bade7c95bd12f6d94ce26f.tar.gz
Switch to the fork of the driver by roadrunner2
- the package now includes a driver for the touchbar found in newer MacBooks - make sure dkms.conf from the AUR is used instead of the original one
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
-rw-r--r--dkms.conf8
3 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cc77a200557..dac27facdd5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
-# Generated by mksrcinfo v8
-# Wed May 3 12:26:24 UTC 2017
pkgbase = macbook12-spi-driver-dkms
- pkgdesc = WIP input driver for the SPI touchpad / keyboard found in the 12" MacBook
- pkgver = 0+git.39
+ pkgdesc = Driver for the keyboard, touchpad and touchbar found in newer MacBook (Pro) models
+ pkgver = 0+git.161
pkgrel = 1
- url = https://github.com/cb22/macbook12-spi-driver
+ url = https://github.com/roadrunner2/macbook12-spi-driver
arch = i686
arch = x86_64
license = GPL2
makedepends = git
depends = dkms
- source = git+https://github.com/cb22/macbook12-spi-driver.git
+ source = git+https://github.com/roadrunner2/macbook12-spi-driver.git#branch=touchbar-driver-hid-driver
source = dkms.conf
sha256sums = SKIP
- sha256sums = 72d908df93de0022dbd5e3cc458a3434105fe61125454a2738587727a42e21b7
+ sha256sums = aae0191e7e7dcc851e61667be5d9a249f36e931ed1e4f2c34dc9eab1501a94fd
pkgname = macbook12-spi-driver-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 6d1d4ddb6cb8..ab29bcb04aa6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+# Maintainer: Andrey Melentyev <andrey.melentyev@protonmail.com>
_pkgbase=macbook12-spi-driver
pkgname=(${_pkgbase}-dkms)
-pkgver=0+git.39
+pkgver=0+git.161
pkgrel=1
-pkgdesc="WIP input driver for the SPI touchpad / keyboard found in the 12\" MacBook"
+pkgdesc="Driver for the keyboard, touchpad and touchbar found in newer MacBook (Pro) models"
arch=('i686' 'x86_64')
-url="https://github.com/cb22/macbook12-spi-driver"
+url="https://github.com/roadrunner2/macbook12-spi-driver"
license=('GPL2')
groups=('')
depends=('dkms')
makedepends=('git')
optdepends=()
-source=(git+https://github.com/cb22/macbook12-spi-driver.git
+source=(git+https://github.com/roadrunner2/macbook12-spi-driver.git#branch=touchbar-driver-hid-driver
dkms.conf)
sha256sums=('SKIP'
- '72d908df93de0022dbd5e3cc458a3434105fe61125454a2738587727a42e21b7')
+ 'aae0191e7e7dcc851e61667be5d9a249f36e931ed1e4f2c34dc9eab1501a94fd')
pkgver() {
cd $_pkgbase
@@ -22,16 +23,16 @@ pkgver() {
}
package() {
- cd "${srcdir}"
-
install -dm755 "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}
+
+ # Copy sources (including Makefile)
+ cp -r ${_pkgbase}/* "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/
+
+ # Copy dkms.conf over the original one from the repo
install -Dm644 dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+ # Set name and version
sed -e "s/@_PKGBASE@/${_pkgbase}/" \
-e "s/@PKGVER@/${pkgver}/" \
-i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
-
- cp -r \
- "${srcdir}"/${_pkgbase}/* \
- "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/
}
diff --git a/dkms.conf b/dkms.conf
index 1b537ee1aa80..f35f9160adf0 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -1,7 +1,11 @@
-PACKAGE_NAME="_PKGBASE"
-PACKAGE_VERSION="PKGVER"
+PACKAGE_NAME="@_PKGBASE@"
+PACKAGE_VERSION="@PKGVER@"
AUTOINSTALL="yes"
+CLEAN="make clean"
BUILT_MODULE_NAME[0]="applespi"
+BUILT_MODULE_NAME[1]="appletb"
MAKE[0]="make KDIR=/usr/lib/modules/$kernelver/build"
+MAKE[1]="make KDIR=/usr/lib/modules/$kernelver/build"
DEST_MODULE_LOCATION[0]="/kernel/drivers/spi"
+DEST_MODULE_LOCATION[1]="/kernel/drivers/misc"