summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2017-05-03 15:24:55 +0300
committerChristoph Gysin2017-05-03 15:26:30 +0300
commit2eca4af8fed1bbe9b58f89e0e129c4d99ca58837 (patch)
tree82b707966f6290693326b8d6f4d0f692198185fd
parent77b0f6c2f68fa1610ef16be1bb1174169c1b5295 (diff)
downloadaur-2eca4af8fed1bbe9b58f89e0e129c4d99ca58837.tar.gz
update to 0+git.39
-rw-r--r--.SRCINFO8
-rw-r--r--0001-add-option-iso_layout.patch118
-rw-r--r--PKGBUILD11
3 files changed, 5 insertions, 132 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c19f4ceb4c5..3cc77a200557 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 27 17:46:44 UTC 2017
+# Wed May 3 12:26:24 UTC 2017
pkgbase = macbook12-spi-driver-dkms
pkgdesc = WIP input driver for the SPI touchpad / keyboard found in the 12" MacBook
- pkgver = 0+git.35
- pkgrel = 2
+ pkgver = 0+git.39
+ pkgrel = 1
url = https://github.com/cb22/macbook12-spi-driver
arch = i686
arch = x86_64
@@ -11,10 +11,8 @@ pkgbase = macbook12-spi-driver-dkms
makedepends = git
depends = dkms
source = git+https://github.com/cb22/macbook12-spi-driver.git
- source = 0001-add-option-iso_layout.patch
source = dkms.conf
sha256sums = SKIP
- sha256sums = 81a95ad335d6e6cfb0c4b5e590be488cd241e039a4c913753e4f6096d57491ad
sha256sums = 72d908df93de0022dbd5e3cc458a3434105fe61125454a2738587727a42e21b7
pkgname = macbook12-spi-driver-dkms
diff --git a/0001-add-option-iso_layout.patch b/0001-add-option-iso_layout.patch
deleted file mode 100644
index cfd152622a83..000000000000
--- a/0001-add-option-iso_layout.patch
+++ /dev/null
@@ -1,118 +0,0 @@
-From a7a73f0dbd485318b0f71405cf350106a6f826c7 Mon Sep 17 00:00:00 2001
-From: Christoph Gysin <christoph.gysin@gmail.com>
-Date: Wed, 19 Apr 2017 17:29:57 +0300
-Subject: [PATCH] add option iso_layout
-
-fixes #12
----
- applespi.c | 61 ++++++++++++++++++++++++++++++++++++++++---------------------
- 1 file changed, 40 insertions(+), 21 deletions(-)
-
-diff --git a/applespi.c b/applespi.c
-index b8fa4cf..e0fb2f7 100644
---- a/applespi.c
-+++ b/applespi.c
-@@ -45,6 +45,10 @@
- #define MAX_FINGERS 6
- #define MAX_FINGER_ORIENTATION 16384
-
-+static unsigned int iso_layout = 1;
-+module_param(iso_layout, uint, 0644);
-+MODULE_PARM_DESC(iso_layout, "Enable/Disable hardcoded ISO-layout of the keyboard. "
-+ "(0 = disabled, [1] = enabled)");
-
- struct keyboard_protocol {
- u16 packet_type;
-@@ -177,6 +181,7 @@ static const unsigned char applespi_scancodes[] = {
- KEY_F1, KEY_F2, KEY_F3, KEY_F4, KEY_F5, KEY_F6, KEY_F7, KEY_F8, KEY_F9,
- KEY_F10, KEY_F11, KEY_F12, 0, 0, 0, 0, 0, 0, 0, 0, 0,
- KEY_RIGHT, KEY_LEFT, KEY_DOWN, KEY_UP,
-+ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, KEY_102ND,
- };
-
- static const unsigned char applespi_controlcodes[] = {
-@@ -191,29 +196,34 @@ static const unsigned char applespi_controlcodes[] = {
- };
-
- struct applespi_key_translation {
-- u8 from;
-+ u16 from;
- u16 to;
- };
-
- static const struct applespi_key_translation applespi_fn_codes[] = {
-- { 42, KEY_DELETE },
-- { 40, KEY_INSERT },
-- { 58, KEY_BRIGHTNESSDOWN },
-- { 59, KEY_BRIGHTNESSUP },
-- { 60, KEY_SCALE },
-- { 61, KEY_DASHBOARD },
-- { 62, KEY_KBDILLUMDOWN },
-- { 63, KEY_KBDILLUMUP },
-- { 64, KEY_PREVIOUSSONG },
-- { 65, KEY_PLAYPAUSE },
-- { 66, KEY_NEXTSONG },
-- { 67, KEY_MUTE },
-- { 68, KEY_VOLUMEDOWN },
-- { 69, KEY_VOLUMEUP },
-- { 82, KEY_PAGEUP },
-- { 81, KEY_PAGEDOWN },
-- { 80, KEY_HOME },
-- { 79, KEY_END },
-+ { KEY_BACKSPACE, KEY_DELETE },
-+ { KEY_ENTER, KEY_INSERT },
-+ { KEY_F1, KEY_BRIGHTNESSDOWN },
-+ { KEY_F2, KEY_BRIGHTNESSUP },
-+ { KEY_F3, KEY_SCALE },
-+ { KEY_F4, KEY_DASHBOARD },
-+ { KEY_F5, KEY_KBDILLUMDOWN },
-+ { KEY_F6, KEY_KBDILLUMUP },
-+ { KEY_F7, KEY_PREVIOUSSONG },
-+ { KEY_F8, KEY_PLAYPAUSE },
-+ { KEY_F9, KEY_NEXTSONG },
-+ { KEY_F10, KEY_MUTE },
-+ { KEY_F11, KEY_VOLUMEDOWN },
-+ { KEY_F12, KEY_VOLUMEUP },
-+ { KEY_RIGHT, KEY_END },
-+ { KEY_LEFT, KEY_HOME },
-+ { KEY_DOWN, KEY_PAGEDOWN },
-+ { KEY_UP, KEY_PAGEUP },
-+};
-+
-+static const struct applespi_key_translation apple_iso_keyboard[] = {
-+ { KEY_GRAVE, KEY_102ND },
-+ { KEY_102ND, KEY_GRAVE },
- };
-
- static u8 *acpi_dsm_uuid = "a0b5b7c6-1318-441c-b0c9-fe695eaf949b";
-@@ -684,16 +694,25 @@ static unsigned int
- applespi_code_to_key(u8 code, int fn_pressed)
- {
- int i;
-+ unsigned int key = applespi_scancodes[code];
-
- if (fn_pressed) {
- for (i=0; i<ARRAY_SIZE(applespi_fn_codes); i++) {
-- if (applespi_fn_codes[i].from == code) {
-+ if (applespi_fn_codes[i].from == key) {
- return applespi_fn_codes[i].to;
- }
- }
- }
-
-- return applespi_scancodes[code];
-+ if (iso_layout) {
-+ for (i=0; i<ARRAY_SIZE(apple_iso_keyboard); i++) {
-+ if (apple_iso_keyboard[i].from == key) {
-+ return apple_iso_keyboard[i].to;
-+ }
-+ }
-+ }
-+
-+ return key;
- }
-
- static void
---
-2.12.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 91519d9a572d..6d1d4ddb6cb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
_pkgbase=macbook12-spi-driver
pkgname=(${_pkgbase}-dkms)
-pkgver=0+git.35
-pkgrel=2
+pkgver=0+git.39
+pkgrel=1
pkgdesc="WIP input driver for the SPI touchpad / keyboard found in the 12\" MacBook"
arch=('i686' 'x86_64')
url="https://github.com/cb22/macbook12-spi-driver"
@@ -12,10 +12,8 @@ depends=('dkms')
makedepends=('git')
optdepends=()
source=(git+https://github.com/cb22/macbook12-spi-driver.git
- 0001-add-option-iso_layout.patch
dkms.conf)
sha256sums=('SKIP'
- '81a95ad335d6e6cfb0c4b5e590be488cd241e039a4c913753e4f6096d57491ad'
'72d908df93de0022dbd5e3cc458a3434105fe61125454a2738587727a42e21b7')
pkgver() {
@@ -23,11 +21,6 @@ pkgver() {
echo "0+git.$(git rev-list HEAD --count)"
}
-build() {
- cd "${srcdir}"/${_pkgbase}
- patch -p1 -i "${srcdir}"/0001-add-option-iso_layout.patch
-}
-
package() {
cd "${srcdir}"