summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2017-04-27 20:47:03 +0300
committerChristoph Gysin2017-04-27 20:47:03 +0300
commit77b0f6c2f68fa1610ef16be1bb1174169c1b5295 (patch)
treecc4f4bf2f058bff69721757240b55e62de30beb7
parent158aac3c23ae85cfe2ea2c4fcf5b24491948b31d (diff)
downloadaur-77b0f6c2f68fa1610ef16be1bb1174169c1b5295.tar.gz
update iso_layout patch
-rw-r--r--.SRCINFO6
-rw-r--r--0001-add-option-iso_layout.patch23
-rw-r--r--PKGBUILD4
3 files changed, 13 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f58b8244251..4c19f4ceb4c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Apr 26 13:36:20 UTC 2017
+# Thu Apr 27 17:46:44 UTC 2017
pkgbase = macbook12-spi-driver-dkms
pkgdesc = WIP input driver for the SPI touchpad / keyboard found in the 12" MacBook
pkgver = 0+git.35
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cb22/macbook12-spi-driver
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = macbook12-spi-driver-dkms
source = 0001-add-option-iso_layout.patch
source = dkms.conf
sha256sums = SKIP
- sha256sums = 0688c4b79408bd10cbcdefbb70d1ecce4b4a3bee725f74bcd066d332983e354a
+ sha256sums = 81a95ad335d6e6cfb0c4b5e590be488cd241e039a4c913753e4f6096d57491ad
sha256sums = 72d908df93de0022dbd5e3cc458a3434105fe61125454a2738587727a42e21b7
pkgname = macbook12-spi-driver-dkms
diff --git a/0001-add-option-iso_layout.patch b/0001-add-option-iso_layout.patch
index 89c7b282939d..cfd152622a83 100644
--- a/0001-add-option-iso_layout.patch
+++ b/0001-add-option-iso_layout.patch
@@ -1,15 +1,15 @@
-From ece075810b575c144aff8996c5d703164ead7cd8 Mon Sep 17 00:00:00 2001
+From a7a73f0dbd485318b0f71405cf350106a6f826c7 Mon Sep 17 00:00:00 2001
From: Christoph Gysin <christoph.gysin@gmail.com>
Date: Wed, 19 Apr 2017 17:29:57 +0300
Subject: [PATCH] add option iso_layout
fixes #12
---
- applespi.c | 64 +++++++++++++++++++++++++++++++++++++++++---------------------
- 1 file changed, 42 insertions(+), 22 deletions(-)
+ applespi.c | 61 ++++++++++++++++++++++++++++++++++++++++---------------------
+ 1 file changed, 40 insertions(+), 21 deletions(-)
diff --git a/applespi.c b/applespi.c
-index b8fa4cf..d11f825 100644
+index b8fa4cf..e0fb2f7 100644
--- a/applespi.c
+++ b/applespi.c
@@ -45,6 +45,10 @@
@@ -23,21 +23,15 @@ index b8fa4cf..d11f825 100644
struct keyboard_protocol {
u16 packet_type;
-@@ -172,11 +176,12 @@ static const unsigned char applespi_scancodes[] = {
- KEY_1, KEY_2, KEY_3, KEY_4, KEY_5, KEY_6, KEY_7, KEY_8, KEY_9, KEY_0,
- KEY_ENTER, KEY_ESC, KEY_BACKSPACE, KEY_TAB, KEY_SPACE, KEY_MINUS,
- KEY_EQUAL, KEY_LEFTBRACE, KEY_RIGHTBRACE, KEY_BACKSLASH, 0,
-- KEY_SEMICOLON, KEY_APOSTROPHE, KEY_GRAVE, KEY_COMMA, KEY_DOT, KEY_SLASH,
-+ KEY_SEMICOLON, KEY_APOSTROPHE, KEY_102ND, KEY_COMMA, KEY_DOT, KEY_SLASH,
- KEY_CAPSLOCK,
+@@ -177,6 +181,7 @@ static const unsigned char applespi_scancodes[] = {
KEY_F1, KEY_F2, KEY_F3, KEY_F4, KEY_F5, KEY_F6, KEY_F7, KEY_F8, KEY_F9,
KEY_F10, KEY_F11, KEY_F12, 0, 0, 0, 0, 0, 0, 0, 0, 0,
KEY_RIGHT, KEY_LEFT, KEY_DOWN, KEY_UP,
-+ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, KEY_GRAVE,
++ 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, KEY_102ND,
};
static const unsigned char applespi_controlcodes[] = {
-@@ -191,29 +196,35 @@ static const unsigned char applespi_controlcodes[] = {
+@@ -191,29 +196,34 @@ static const unsigned char applespi_controlcodes[] = {
};
struct applespi_key_translation {
@@ -88,11 +82,10 @@ index b8fa4cf..d11f825 100644
+static const struct applespi_key_translation apple_iso_keyboard[] = {
+ { KEY_GRAVE, KEY_102ND },
+ { KEY_102ND, KEY_GRAVE },
-+ { }
};
static u8 *acpi_dsm_uuid = "a0b5b7c6-1318-441c-b0c9-fe695eaf949b";
-@@ -684,16 +695,25 @@ static unsigned int
+@@ -684,16 +694,25 @@ static unsigned int
applespi_code_to_key(u8 code, int fn_pressed)
{
int i;
diff --git a/PKGBUILD b/PKGBUILD
index 65eadd094d5a..91519d9a572d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgbase=macbook12-spi-driver
pkgname=(${_pkgbase}-dkms)
pkgver=0+git.35
-pkgrel=1
+pkgrel=2
pkgdesc="WIP input driver for the SPI touchpad / keyboard found in the 12\" MacBook"
arch=('i686' 'x86_64')
url="https://github.com/cb22/macbook12-spi-driver"
@@ -15,7 +15,7 @@ source=(git+https://github.com/cb22/macbook12-spi-driver.git
0001-add-option-iso_layout.patch
dkms.conf)
sha256sums=('SKIP'
- '0688c4b79408bd10cbcdefbb70d1ecce4b4a3bee725f74bcd066d332983e354a'
+ '81a95ad335d6e6cfb0c4b5e590be488cd241e039a4c913753e4f6096d57491ad'
'72d908df93de0022dbd5e3cc458a3434105fe61125454a2738587727a42e21b7')
pkgver() {