summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2017-04-19 13:07:34 +0300
committerChristoph Gysin2017-04-19 13:08:07 +0300
commite459a2eb7252f83f552674b466aa7e547ef59078 (patch)
treecf1bb942361521ae12e82f6904d16f2058fada73
downloadaur-e459a2eb7252f83f552674b466aa7e547ef59078.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
-rw-r--r--dkms.conf7
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e92bb12b5d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Apr 19 10:08:00 UTC 2017
+pkgbase = macbook12-spi-driver-dkms
+ pkgdesc = WIP input driver for the SPI touchpad / keyboard found in the 12" MacBook
+ pkgver = 0+git.25
+ pkgrel = 1
+ url = https://github.com/cb22/macbook12-spi-driver
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = dkms
+ source = git+https://github.com/cb22/macbook12-spi-driver.git
+ source = dkms.conf
+ sha256sums = SKIP
+ sha256sums = 72d908df93de0022dbd5e3cc458a3434105fe61125454a2738587727a42e21b7
+
+pkgname = macbook12-spi-driver-dkms
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..802cfe076bb6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.tar.*
+/macbook12-spi-driver/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01fb591c574a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Christoph Gysin <christoph.gysin@gmail.com>
+_pkgbase=macbook12-spi-driver
+pkgname=(${_pkgbase}-dkms)
+pkgver=0+git.25
+pkgrel=1
+pkgdesc="WIP input driver for the SPI touchpad / keyboard found in the 12\" MacBook"
+arch=('i686' 'x86_64')
+url="https://github.com/cb22/macbook12-spi-driver"
+license=('GPL2')
+groups=('')
+depends=('dkms')
+makedepends=('git')
+optdepends=()
+source=(git+https://github.com/cb22/macbook12-spi-driver.git
+ dkms.conf)
+sha256sums=('SKIP'
+ '72d908df93de0022dbd5e3cc458a3434105fe61125454a2738587727a42e21b7')
+
+pkgver() {
+ cd $_pkgbase
+ echo "0+git.$(git rev-list HEAD --count)"
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm755 "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}
+ install -Dm644 dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+
+ sed -e "s/@_PKGBASE@/${_pkgbase}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+
+ cp -r \
+ "${srcdir}"/${_pkgbase}/* \
+ "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/
+}
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..1b537ee1aa80
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,7 @@
+PACKAGE_NAME="_PKGBASE"
+PACKAGE_VERSION="PKGVER"
+AUTOINSTALL="yes"
+
+BUILT_MODULE_NAME[0]="applespi"
+MAKE[0]="make KDIR=/usr/lib/modules/$kernelver/build"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/spi"