aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2019-01-15 14:11:42 +1100
committerJP-Ellis2019-01-15 14:11:54 +1100
commit6d57f3ca6fda86472f36e4a63fecbb7b68ba13f3 (patch)
tree5da8ab35ed0b3b4fcd3b94181564ddc617b57fae
parent280888c25e51b7435de55cf591b4fbb88401821c (diff)
downloadaur-6d57f3ca6fda86472f36e4a63fecbb7b68ba13f3.tar.gz
Update to v2.6.4
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
-rw-r--r--python2.patch2
3 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21d140b9bb9b..89b516d22143 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jun 26 02:53:56 UTC 2018
+# Tue Jan 15 03:11:28 UTC 2019
pkgbase = madgraph
pkgdesc = MadGraph5_aMC@NLO is a framework that aims at providing all the elements necessary for SM and BSM phenomenology
- pkgver = 2.6.3.2
+ pkgver = 2.6.4
pkgrel = 1
url = https://launchpad.net/mg5amcnlo
arch = i686
@@ -22,13 +22,11 @@ pkgbase = madgraph
optdepends = madgraph-pythia-pgs
optdepends = madgraph-pythia8-interface
options = !strip
- source = https://launchpad.net/mg5amcnlo/2.0/2.6.x/+download/MG5_aMC_v2.6.3.2.tar.gz
+ source = https://launchpad.net/mg5amcnlo/2.0/2.6.x/+download/MG5_aMC_v2.6.4.tar.gz
source = python2.patch
- source = gcc8.patch
source = mg5_configuration.patch
- sha256sums = 834c9bcb98e21c214d5287f0dab65a982914a5c388173bcedd32d0d25c739f50
- sha256sums = f1f90b0b470b2ea97e4c9ad2f9c15085d4ef6479c1a94ceb71a8078ec79ff1b8
- sha256sums = 3031fff92bcb616e2d53ef206341355e63130ccc9e23f77ce8d1baf98fdb90db
+ sha256sums = ec7f13018433888319536adba436012fca4a2ccb715b2f525c7efa5e870e7605
+ sha256sums = 2b84d4122542c25957c43f0dd20080040d65c1b7f666402a4a45676e04c6d0df
sha256sums = a251d1bc6be29032c051cde8b0d050330b4777ff94fea6df5a495a9506c4eadc
pkgname = madgraph
diff --git a/PKGBUILD b/PKGBUILD
index 741633916a9c..478ad5066252 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: JP-Ellis <josh@jpellis.me>
pkgname=madgraph
-pkgver=2.6.3.2
+pkgver=2.6.4
_major=${pkgver%%.*}
_minor=${pkgver#2.}
_minor=${_minor%%.*}
@@ -30,11 +30,9 @@ optdepends=(
)
source=("https://launchpad.net/mg5amcnlo/${_major}.0/${_major}.${_minor}.x/+download/MG5_aMC_v${pkgver}.tar.gz"
"python2.patch"
- "gcc8.patch"
"mg5_configuration.patch")
-sha256sums=('834c9bcb98e21c214d5287f0dab65a982914a5c388173bcedd32d0d25c739f50'
- 'f1f90b0b470b2ea97e4c9ad2f9c15085d4ef6479c1a94ceb71a8078ec79ff1b8'
- '3031fff92bcb616e2d53ef206341355e63130ccc9e23f77ce8d1baf98fdb90db'
+sha256sums=('ec7f13018433888319536adba436012fca4a2ccb715b2f525c7efa5e870e7605'
+ '2b84d4122542c25957c43f0dd20080040d65c1b7f666402a4a45676e04c6d0df'
'a251d1bc6be29032c051cde8b0d050330b4777ff94fea6df5a495a9506c4eadc')
options=("!strip")
@@ -42,9 +40,6 @@ prepare() {
msg2 "Fixing python references for python2"
patch -p 1 -d $_dirname < python2.patch
- msg2 "Patching for GCC 8"
- patch -p 1 -d $_dirname < gcc8.patch
-
msg2 "Extracting documentation"
cd "${srcdir}/${_dirname}"
tar xf doc.tgz
diff --git a/python2.patch b/python2.patch
index b45343ed0839..c4bb2180ec11 100644
--- a/python2.patch
+++ b/python2.patch
@@ -482,7 +482,7 @@ diff -ur tests/acceptance_tests/test_histograms.py tests/acceptance_tests/test_h
diff -ur tests/acceptance_tests/test_model_equivalence.py tests/acceptance_tests/test_model_equivalence.py
--- a/tests/acceptance_tests/test_model_equivalence.py
+++ b/tests/acceptance_tests/test_model_equivalence.py
-@@ -323,7 +323,7 @@
+@@ -322,7 +322,7 @@
pass
# prepare for a local compilation