aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2016-05-29 23:33:34 +1000
committerJP-Ellis2016-05-30 00:26:49 +1000
commitb8fe5e5638a3ffe841329329410667dafc5bb009 (patch)
tree50c5dbbd4a7d8113e01dcf53c769b2909f1088eb
downloadaur-b8fe5e5638a3ffe841329329410667dafc5bb009.tar.gz
Initial commit.
Signed-off-by: JP-Ellis <josh@jpellis.me>
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD133
-rw-r--r--README.org3
4 files changed, 159 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c260fca146e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun May 29 14:26:44 UTC 2016
+pkgbase = madgraph
+ pkgdesc = MadGraph5_aMC@NLO is a framework that aims at providing all the elements necessary for SM and BSM phenomenology
+ pkgver = 2.4.0
+ pkgrel = 20160513
+ url = http://madgraph.hep.uiuc.edu/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python2
+ depends = bash
+ depends = perl
+ depends = tcsh
+ depends = gcc-fortran
+ options = !strip
+ source = http://madgraph.hep.uiuc.edu/Downloads/MG5_aMC_v2.4.0.tar.gz
+ sha256sums = 9571bcdefb4a15546db1d403f6d2818fc4d21033558ca2a7d376cc71d197aa66
+
+pkgname = madgraph
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9d22fe65f18c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/MG5*.tar.gz
+/madgraph*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7df6aec4cacc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,133 @@
+# Maintainer: JP-Ellis <josh@jpellis.me>
+
+pkgname=madgraph
+pkgver=2.4.0
+_dirname="MG5_aMC_v${pkgver//./_}"
+pkgrel=20160513
+pkgdesc="MadGraph5_aMC@NLO is a framework that aims at providing all the elements necessary for SM and BSM phenomenology"
+url="http://madgraph.hep.uiuc.edu/"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('python2' 'bash' 'perl' 'tcsh' 'gcc-fortran')
+source=("http://madgraph.hep.uiuc.edu/Downloads/MG5_aMC_v${pkgver}.tar.gz")
+sha256sums=('9571bcdefb4a15546db1d403f6d2818fc4d21033558ca2a7d376cc71d197aa66')
+options=("!strip")
+
+prepare() {
+ echo "################################################################################"
+ echo "Patching python -> python2"
+ cd ${srcdir}/${_dirname}
+ find . -type f -print0 | xargs -0 sed -i 's|^#!\s*/usr/bin/env\s\+python\s*$|#!/usr/bin/env python2|'
+ find . -type f -print0 | xargs -0 sed -i 's|^#!\s*/usr/bin/python\s*$|#!/usr/bin/env python2|'
+ echo "################################################################################"
+ echo "Building CutTools"
+ cd ${srcdir}/${_dirname}/vendor/CutTools
+ make -j1
+ make clean
+ echo "################################################################################"
+ # DisceteSampler doesn't compile (if someone needs this, I welcome a patch)
+ # echo ""
+ # echo "################################################################################"
+ # echo "Building DiscreteSampler"
+ # cd ${srcdir}/${_dirname}/vendor/DiscreteSampler
+ # make
+ # make clean
+ # echo "################################################################################"
+ echo ""
+ echo "################################################################################"
+ echo "Building IREGI"
+ cd ${srcdir}/${_dirname}/vendor/IREGI/src
+ make
+ make clean
+ echo "################################################################################"
+ echo ""
+ echo "################################################################################"
+ echo "Building SMWidth"
+ cd ${srcdir}/${_dirname}/vendor/SMWidth
+ make
+ make clean
+ echo "################################################################################"
+ echo ""
+ echo "################################################################################"
+ echo "Building StdHEP"
+ cd ${srcdir}/${_dirname}/vendor/StdHEP
+ make
+ make clean
+ echo "################################################################################"
+ echo ""
+ echo "################################################################################"
+ echo "Building Ninja"
+ cd ${srcdir}/${_dirname}/vendor/
+ tar xf ninja.tar.gz
+ rm ninja.tar.gz
+ cd ninja-1.1.0
+ ./configure
+ make
+ make clean
+ echo "################################################################################"
+ echo ""
+ echo "################################################################################"
+ echo "Building OneLoop"
+ cd ${srcdir}/${_dirname}/vendor/
+ tar xf oneloop.tar.gz
+ rm oneloop.tar.gz
+ cd OneLOop-3.6
+ ./create.py
+ ./clean.sh
+ echo "################################################################################"
+ echo ""
+ echo "################################################################################"
+ echo "Extracting documentation"
+ cd ${srcdir}/${_dirname}
+ tar xf doc.tgz
+ rm doc.tgz
+
+ echo "Patching python -> python2"
+ cd ${srcdir}/${_dirname}
+ find . -type f -print0 | xargs -0 sed -i 's|^#!\s*/usr/bin/env\s\+python\s*$|#!/usr/bin/env python2|'
+ find . -type f -print0 | xargs -0 sed -i 's|^#!\s*/usr/bin/python\s*$|#!/usr/bin/env python2|'
+
+ echo "Patching root_path"
+ cd ${srcdir}/${_dirname}
+ find . -type f -print0 | xargs -0 sed -i 's|^\(\s*\)root_path\s*=.*$|\1root_path = "/usr/share/madgraph"|'
+
+ echo "Removing CVS directories"
+ cd ${srcdir}/${_dirname}
+ find . -type d -name "CVS" | xargs rm -rf
+ find . -type f -name ".bzrignore" | xargs rm -f
+ find . -type f -name ".bzr" | xargs rm -rf
+ echo "################################################################################"
+
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_dirname}/bin/mg5" "${pkgdir}/usr/bin/mg5"
+ install -Dm755 "${srcdir}/${_dirname}/bin/mg5_aMC" "${pkgdir}/usr/bin/mg5_aMC"
+ install -Dm755 "${srcdir}/${_dirname}/aloha/bin/aloha" "${pkgdir}/usr/bin/aloha"
+ install -Dm755 "${srcdir}/${_dirname}/MadSpin/madspin" "${pkgdir}/usr/bin/madspin"
+
+ install -Dm655 "${srcdir}/${_dirname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ cp -a "${srcdir}/${_dirname}/." "${pkgdir}/usr/share/${pkgname}"
+ rm -r "${pkgdir}/usr/share/${pkgname}/bin"
+ rm -r "${pkgdir}/usr/share/${pkgname}/aloha/bin"
+ rm "${pkgdir}/usr/share/${pkgname}/MadSpin/madspin"
+
+ find "${pkgdir}/usr/share/${pkgname}" -type f -print0 | xargs -0 chmod 644
+ find "${pkgdir}/usr/share/${pkgname}" -type f -path "*/bin/*" -print0 | xargs -0 chmod 755
+
+ echo ""
+ echo "If you use MadGraph, please cite:"
+ echo "-----------------------------------------------------------------"
+ echo "Alwall, J., et al. \"The automated computation of tree-level and"
+ echo "next-to-leading order differential cross sections, and their"
+ echo "matching to parton shower simulations.\" Journal of High Energy"
+ echo "Physics 2014.7 (2014): 1-157."
+ echo "-----------------------------------------------------------------"
+ echo ""
+}
+
+# Local Variables:
+# mode: sh
+# End:
diff --git a/README.org b/README.org
new file mode 100644
index 000000000000..1d33baeb5610
--- /dev/null
+++ b/README.org
@@ -0,0 +1,3 @@
+#+TITLE: madgraph [[https://aur.archlinux.org/packages/madgraph/][https://img.shields.io/aur/version/madgraph.svg]]
+
+MadGraph bundled for installation on Arch Linux.