summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-01-29 18:23:35 -0600
committerLuis Martinez2022-01-29 18:23:35 -0600
commit5a80a7de7fef31355b50598bafc9bf178b4bdc5a (patch)
tree05541aa0447378bd1ccf47978432e1e6aedbd86c
parent160c74774306605316aca100ed36fc672015ffb9 (diff)
downloadaur-5a80a7de7fef31355b50598bafc9bf178b4bdc5a.tar.gz
update to 1.5.3
-rw-r--r--.SRCINFO11
-rw-r--r--CHANGELOG.md46
-rw-r--r--PKGBUILD15
3 files changed, 55 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ff036ae0de8..b7a7342ca023 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = maestral-qt
pkgdesc = Qt interface for Maestral
- pkgver = 1.5.2
+ pkgver = 1.5.3
pkgrel = 1
url = https://github.com/SamSchott/maestral-qt
changelog = CHANGELOG.md
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-install
makedepends = python-wheel
- depends = maestral=1.5.2
+ depends = maestral>=1.5.3
depends = python-click
depends = python-markdown2
depends = python-packaging
depends = python-pyqt5
optdepends = gnome-shell-extension-appindicator: Gnome integration
- source = maestral-qt-1.5.2.tar.gz::https://github.com/SamSchott/maestral-qt/archive/v1.5.2.tar.gz
- sha256sums = 5decf5f44f52771be7c5559e5b0db777fcd02704b5a116ebfdd55b779475b5dd
+ source = maestral-qt-1.5.3.tar.gz::https://github.com/SamSchott/maestral-qt/archive/v1.5.3.tar.gz
+ sha256sums = d8f85c1cc3e5449f494c81f490997d6b4c300c3829b7a4ee5c1841cdc718a3f5
pkgname = maestral-qt
diff --git a/CHANGELOG.md b/CHANGELOG.md
index c4d5ce1ba6ec..ab051844803e 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,12 +1,48 @@
-## v1.5.2.dev
+## v1.5.3.dev
+
+#### Changed:
+
+* The Dock icon no longer appears while the app is launching in macOS.
+* The Dock icon no longer appears when clicking on a desktop notification on macOS.
+* Clicking on a desktop notification will now show the file or folder which triggered the
+ notification. Previously, only clicking on the "Show" button of the notification
+ would open the file browser.
+* Removed update notifications by the CLI.
+* Proper symlink handling: Remote items which are symlinks will now be synced as symlinks
+ instead of empty files. Local symlinks will no longer be followed during indexing or
+ silently ignored when syncing. Instead, attempting to upload a symlink will raise an
+ error because uploading symlinks is not currently supported by the public Dropbox API.
+
+#### Fixed:
+
+* Fixes a crash of the `maestral activity` CLI command when run from the macOS App Bundle
+ due to a missing packaged library.
+* Fixes an issue which prevented the `maestral gui` command from working with the macOS
+ app bundle.
+* Fixes an issue where moving a local file to overwrite another file, for example with mv
+ in the terminal, could generate an incorrect conflicting copy during upload sync.
+* Properly handle when the local Dropbox directory is renamed by changing the casing only
+ on case-insensitive file systems such as APFS on macOS.
+* Fixes an issue which could result in sync errors not being cleared after the successful
+ sync of an item under some circumstances.
+* Relative passed to `maestral move-dir` are now interpreted relative to the working
+ directory where the command is run instead of the working directory of the sync daemon.
+
+## v1.5.2
+
+#### Changed:
+
+* Improved dialog flow on Linux when the local Dropbox folder is missing.
+* Improved error handling when determining the change time (ctime) of a local file fails.
#### Fixed:
-* Fixes an issue where the output of CLI commands would get truncated to 80 chars when
- piped to another command and not attached to an interactive stream such as a terminal.
-* Improve handling of OSErrors when determining the ctime of a local file.
-* Python 3.10 compatibility of Linux (Qt) GUI, thanks to @raffaem.
+* Fixes an issue where the output of CLI commands would get truncated to 80 characters
+ when piped to another command and not attached to an interactive stream such as a
+ terminal.
+* Fixes Python 3.10 compatibility of Linux (Qt) GUI, thanks to @raffaem.
* Fixes an issue where the CLI fails to install on Apple Silicon Macs.
+* Fixes a startup loop of the Linux GUI when the local Dropbox folder is missing.
## v1.5.1
diff --git a/PKGBUILD b/PKGBUILD
index bb0ae20f5127..981026e98fd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,32 @@
# Contributor: Batuhan Baserdem <lastname dot firstname at gmail>
pkgname=maestral-qt
-pkgver=1.5.2
+pkgver=1.5.3
pkgrel=1
pkgdesc='Qt interface for Maestral'
arch=('any')
url="https://github.com/SamSchott/maestral-qt"
license=('MIT')
depends=(
- "maestral=$pkgver"
+ "maestral>=$pkgver"
'python-click'
'python-markdown2'
'python-packaging'
'python-pyqt5')
optdepends=('gnome-shell-extension-appindicator: Gnome integration')
-makedepends=('python-setuptools' 'python-wheel')
+makedepends=('python-build' 'python-install' 'python-wheel')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('5decf5f44f52771be7c5559e5b0db777fcd02704b5a116ebfdd55b779475b5dd')
+sha256sums=('d8f85c1cc3e5449f494c81f490997d6b4c300c3829b7a4ee5c1841cdc718a3f5')
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
+ export PYTHONHASHSEED=0
cd "$pkgname-$pkgver"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm 644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}