summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Epaneshnikov2021-07-13 01:01:22 +0300
committerAlexander Epaneshnikov2021-07-13 21:15:50 +0300
commit167b951f4a7e938b73c56680c19b8dc8d7df2d52 (patch)
tree9116e6cfcdb2a09eebb38d8c7e1a3cf0bb4021e7
parenta6faba2d6a526a09352f133acb25bd52f62729a9 (diff)
downloadaur-167b951f4a7e938b73c56680c19b8dc8d7df2d52.tar.gz
improve pkgbuild
install documentation, manpage and license. also run tests.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
2 files changed, 28 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb448d1fe2f7..cdba0e8334ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = magic-wormhole
pkgdesc = Securely transfer data between computers
pkgver = 0.12.0
- pkgrel = 2
- url = https://pypi.python.org/pypi/magic-wormhole/0.12.0
+ pkgrel = 3
+ url = https://github.com/magic-wormhole/magic-wormhole
arch = any
license = MIT
+ checkdepends = python-mock
+ checkdepends = python-magic-wormhole-transit-relay
+ checkdepends = python-magic-wormhole-mailbox-server
makedepends = python-setuptools
depends = python-click
depends = python-cffi
@@ -27,7 +30,7 @@ pkgbase = magic-wormhole
replaces = wormhole
replaces = wormhole-server
replaces = python-wormhole
- source = https://files.pythonhosted.org/packages/source/m/magic-wormhole/magic-wormhole-0.12.0.tar.gz
- sha512sums = 0ef4241a5692227206c1a07a2aed8a2c1575281d52db8bcdb8ffd070c158b4969126486b5e68e899f2100d7daedbbe0b91a7d667915bd5b86be26d6553b34dd6
+ source = magic-wormhole-0.12.0.tar.gz::https://github.com/magic-wormhole/magic-wormhole/archive/refs/tags/0.12.0.tar.gz
+ sha512sums = 141244e746b0718f2c9417e8f7de6a714b0feb051aea8c7950ea0d1bc5d2e24e922bed29544fe76aa61b06aa2ce2b5f330824017af8c6030813415e6c004c716
pkgname = magic-wormhole
diff --git a/PKGBUILD b/PKGBUILD
index 85325cfe2266..5a4ac4505a0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,36 @@
-# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+# Maintainer: Alexander Epaneshnikov <aarnaarn2@gmail.com>
-pkgname='magic-wormhole'
+pkgname=magic-wormhole
pkgver=0.12.0
-pkgrel=2
+pkgrel=3
pkgdesc="Securely transfer data between computers"
arch=('any')
-url="https://pypi.python.org/pypi/${pkgname}/${pkgver}"
+url="https://github.com/magic-wormhole/magic-wormhole"
license=('MIT')
depends=('python-click' 'python-cffi' 'python-autobahn' 'python-tqdm' 'python-hkdf' 'python-pynacl' 'python-spake2' 'python-humanize' 'python-idna' 'python-service-identity' 'python-txtorcon' 'python-pyopenssl')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-conflicts=("wormhole" "wormhole-server" "python-wormhole")
-provides=("wormhole" "wormhole-server" "python-wormhole")
-replaces=("wormhole" "wormhole-server" "python-wormhole")
-sha512sums=('0ef4241a5692227206c1a07a2aed8a2c1575281d52db8bcdb8ffd070c158b4969126486b5e68e899f2100d7daedbbe0b91a7d667915bd5b86be26d6553b34dd6')
+checkdepends=('python-mock' 'python-magic-wormhole-transit-relay' 'python-magic-wormhole-mailbox-server')
+provides=('wormhole' 'wormhole-server' 'python-wormhole')
+conflicts=('wormhole' 'wormhole-server' 'python-wormhole')
+replaces=('wormhole' 'wormhole-server' 'python-wormhole')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/magic-wormhole/magic-wormhole/archive/refs/tags/${pkgver}.tar.gz")
+sha512sums=('141244e746b0718f2c9417e8f7de6a714b0feb051aea8c7950ea0d1bc5d2e24e922bed29544fe76aa61b06aa2ce2b5f330824017af8c6030813415e6c004c716')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
python setup.py build
}
+check() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py test
+}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
+ install -vDm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -vDm 644 docs/*.md -t "${pkgdir}/usr/share/docs/${pkgname}"
+ install -vDm 644 docs/wormhole.1 -t "${pkgdir}/usr/share/man/man1"
}