summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2019-02-16 13:56:57 -0500
committerStorm Dragon2019-02-16 13:56:57 -0500
commite9c48a3f4aea4a5c8b31de9e4568d0ed7dc68bde (patch)
tree526fd65f8e3ff529c4a4706e92bff38c4497cbd5
parenta20d4fd7cbeecc93b06841f8cc024a29ce372b29 (diff)
downloadaur-e9c48a3f4aea4a5c8b31de9e4568d0ed7dc68bde.tar.gz
Magic-wormhole is no longer a split package. It never worked right anyway.
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD38
2 files changed, 16 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f655cb58d90a..e91c9e71c1d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Dec 10 15:37:27 UTC 2018
+# Sat Feb 16 18:55:44 UTC 2019
pkgbase = magic-wormhole
pkgdesc = Securely transfer data between computers
pkgver = 0.11.2
@@ -7,66 +7,30 @@ pkgbase = magic-wormhole
url = https://pypi.python.org/pypi/magic-wormhole/0.11.2
arch = any
license = MIT
- makedepends = python2-setuptools
makedepends = python-setuptools
depends = python-click
- depends = python2-click
depends = python-cffi
- depends = python2-cffi
depends = python-autobahn
- depends = python2-autobahn
depends = python-tqdm
- depends = python2-tqdm
depends = python-hkdf
- depends = python2-hkdf
depends = python-pynacl
- depends = python2-pynacl
depends = python-spake2
- depends = python2-spake2
depends = python-humanize
depends = python-idna
- depends = python2-idna
depends = python-service-identity
- depends = python2-service-identity
depends = python-ipaddress
- depends = python2-ipaddress
depends = python-txtorcon
- depends = python2-txtorcon
provides = wormhole
provides = wormhole-server
+ provides = python-wormhole
conflicts = wormhole
conflicts = wormhole-server
+ conflicts = python-wormhole
replaces = wormhole
replaces = wormhole-server
+ replaces = python-wormhole
source = https://files.pythonhosted.org/packages/source/m/magic-wormhole/magic-wormhole-0.11.2.tar.gz
sha512sums = 890c0f1f946dfd9a9bde2ec0079c55dc23b328e04780e6baf8c580dfd068bf37a5b2e00e12119be6529a6e0893d4f711145e04c349ccfdf7ef91e87cef785d36
-pkgname = python2-magic-wormhole
- pkgdesc = Securely transfer data between computers
- depends = python2-click
- depends = python2-cffi
- depends = python2-autobahn
- depends = python2-tqdm
- depends = python2-hkdf
- depends = python2-pynacl
- depends = python2-spake2
- depends = python2-idna
- depends = python2-service-identity
- depends = python2-ipaddress
- depends = python2-txtorcon
-
-pkgname = python-magic-wormhole
- pkgdesc = Securely transfer data between computers
- depends = python-click
- depends = python-cffi
- depends = python-autobahn
- depends = python-tqdm
- depends = python-hkdf
- depends = python-pynacl
- depends = python-spake2
- depends = python-humanize
- depends = python-idna
- depends = python-service-identity
- depends = python-ipaddress
- depends = python-txtorcon
+pkgname = magic-wormhole
diff --git a/PKGBUILD b/PKGBUILD
index 73e1d99c3602..16a204b5129e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,26 @@
# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
-pkgbase=magic-wormhole
-_pkgname='magic-wormhole'
-pkgname=('python2-magic-wormhole' 'python-magic-wormhole')
+pkgname='magic-wormhole'
pkgver=0.11.2
pkgrel=1
pkgdesc="Securely transfer data between computers"
arch=('any')
-url="https://pypi.python.org/pypi/${_pkgname}/${pkgver}"
+url="https://pypi.python.org/pypi/${pkgname}/${pkgver}"
license=('MIT')
-depends=('python-click' 'python2-click' 'python-cffi' 'python2-cffi' 'python-autobahn' 'python2-autobahn' 'python-tqdm' 'python2-tqdm' 'python-hkdf' 'python2-hkdf' 'python-pynacl' 'python2-pynacl' 'python-spake2' 'python2-spake2' 'python-humanize' 'python-idna' 'python2-idna' 'python-service-identity' 'python2-service-identity' 'python-ipaddress' 'python2-ipaddress' 'python-txtorcon' 'python2-txtorcon')
-makedepends=('python2-setuptools' 'python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-conflicts=("wormhole" "wormhole-server")
-provides=("wormhole" "wormhole-server")
-replaces=("wormhole" "wormhole-server")
+depends=('python-click' 'python-cffi' 'python-autobahn' 'python-tqdm' 'python-hkdf' 'python-pynacl' 'python-spake2' 'python-humanize' 'python-idna' 'python-service-identity' 'python-ipaddress' 'python-txtorcon')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+conflicts=("wormhole" "wormhole-server" "python-wormhole")
+provides=("wormhole" "wormhole-server" "python-wormhole")
+replaces=("wormhole" "wormhole-server" "python-wormhole")
sha512sums=('890c0f1f946dfd9a9bde2ec0079c55dc23b328e04780e6baf8c580dfd068bf37a5b2e00e12119be6529a6e0893d4f711145e04c349ccfdf7ef91e87cef785d36')
-prepare() {
- cp -a ${_pkgname}-${pkgver}{,-py2}
-}
-
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py build
- python2 setup.py build
-}
-
-package_python2-magic-wormhole() {
- pkgdesc="Securely transfer data between computers"
- depends=('python2-click' 'python2-cffi' 'python2-autobahn' 'python2-tqdm' 'python2-hkdf' 'python2-pynacl' 'python2-spake2' 'python2-idna' 'python2-service-identity' 'python2-ipaddress' 'python2-txtorcon')
- cd "${srcdir}/${_pkgname}-${pkgver}"-py2
- python2 setup.py install --root="${pkgdir}/" --optimize=1
}
-package_python-magic-wormhole() {
- pkgdesc="Securely transfer data between computers"
- depends=('python-click' 'python-cffi' 'python-autobahn' 'python-tqdm' 'python-hkdf' 'python-pynacl' 'python-spake2' 'python-humanize' 'python-idna' 'python-service-identity' 'python-ipaddress' 'python-txtorcon')
- cd "${srcdir}/${_pkgname}-${pkgver}"
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1
}