summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Muehlhaeuser2020-01-30 06:58:15 +0100
committerChristian Muehlhaeuser2020-01-30 06:58:15 +0100
commite4e75ebbb3d89a9302a21fbc605fca3d16b69f24 (patch)
treebe067bbd7c1505991501c486abc2f1ab0fc24fca
downloadaur-magicwand.tar.gz
Initial commit for package magicwand
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18626f82b32e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = magicwand
+ pkgdesc = MagicWand makes your input devices context sensitive
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/muesli/magicwand
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ source = https://github.com/muesli/magicwand/archive/v0.1.0.tar.gz
+ sha256sums = 381e5eccfa512f484e1b0536a76d72e53c9bc46da99fafeb398c61ca1adff983
+
+pkgname = magicwand
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b11b299d5654
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Christian Muehlhaeuser <muesli at gmail dot com>
+
+pkgname=magicwand
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="MagicWand makes your input devices context sensitive"
+arch=('x86_64')
+url="https://github.com/muesli/magicwand"
+license=('MIT')
+makedepends=('go')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('381e5eccfa512f484e1b0536a76d72e53c9bc46da99fafeb398c61ca1adff983')
+
+build() {
+ cd "$pkgname-$pkgver"
+ go build \
+ -trimpath \
+ -ldflags "-X main.Version=$pkgver -extldflags $LDFLAGS" \
+ -o "magicwand" .
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "magicwand" "$pkgdir/usr/bin/magicwand"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}