summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimír Vondruš2024-04-02 16:20:44 +0200
committerVladimír Vondruš2024-04-02 16:20:44 +0200
commitccf4b870106e6ce02551260d3ed09d5744292140 (patch)
tree6c02e21375c7779b02f455873a09c4155a9eaf1a
parent3199ee9769450545a565357d8984174aeea2b1e2 (diff)
downloadaur-magnum-git.tar.gz
Fix LTO behavior for static Application libraries.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 854d68c21f2c..1d796d6ccbc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = magnum-git
pkgdesc = C++11/C++14 graphics middleware for games and data visualization (Git version)
- pkgver = 2020.06.r1626.g67d37c9ed
+ pkgver = 2020.06.r2855.g8538610fa
pkgrel = 1
url = https://magnum.graphics
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 68480f08c71f..a0cf5a6789b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Author: mosra <mosra@centrum.cz>
pkgname=magnum-git
-pkgver=2020.06.r1626.g67d37c9ed
+pkgver=2020.06.r2855.g8538610fa
pkgrel=1
pkgdesc="C++11/C++14 graphics middleware for games and data visualization (Git version)"
arch=('i686' 'x86_64')
@@ -22,6 +22,13 @@ build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
+ # Otherwise lib*Application.a and other static libraries get broken during
+ # a strip, subsequently failing to link.
+ # https://archlinux.org/todo/lto-fat-objects/
+ if [[ $CXXFLAGS == *"-flto"* ]]; then
+ CXXFLAGS+=" -ffat-lto-objects"
+ fi
+
cmake "$srcdir/${pkgname%-git}" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \