summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 07:19:52 +1300
committercaltlgin2020-12-03 07:19:52 +1300
commit6ea6adf6eeffe8ea672dd72fc076a52f27f64b9f (patch)
tree9ef416dd7b4547a015239054fc8e49944910e284
parentddc351539a9d1e8be70cfa282f98d5d98df1e3f2 (diff)
downloadaur-mailman-rss.tar.gz
Python 3.9 rebuild
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bdada47268b..f60ea1aa443c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = mailman-rss
pkgdesc = Mailman archive to rss/twitter bot
pkgver = 0.2.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kyamagu/mailman-rss
arch = any
license = MIT
makedepends = python-setuptools
+ depends = python
depends = python-beautifulsoup4
depends = python-dateutil
depends = python-future
depends = python-requests
optdepends = python-twitter: twitter bot functionality
source = https://files.pythonhosted.org/packages/source/m/mailman-rss/mailman-rss-0.2.4.tar.gz
- source = mailman-rss-0.2.4-LICENSE::https://raw.githubusercontent.com/kyamagu/mailman-rss/master/LICENSE
+ source = mailman-rss-license-4722888c7c4b1ecb2042a10f8cf96f5936287396::https://github.com/kyamagu/mailman-rss/raw/4722888c7c4b1ecb2042a10f8cf96f5936287396/LICENSE
sha256sums = 0030e2ba55cf77b96d8777956270909cc68b77a7d5314093ea4f7909ce8c39af
- sha256sums = SKIP
+ sha256sums = 27d5c197628d3e10c3f9cb2bf6c1a9d8049834e633bb0ead3cb783418823cbbe
pkgname = mailman-rss
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 028123703afc..226219641401 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-pkgname=mailman-rss
+pkgname='mailman-rss'
+
pkgver=0.2.4
-pkgrel=1
+pkgrel=2
+_commit_license='4722888c7c4b1ecb2042a10f8cf96f5936287396'
+
pkgdesc='Mailman archive to rss/twitter bot'
arch=('any')
url='https://github.com/kyamagu/mailman-rss'
-_rawurl="https://raw.githubusercontent.com/${url##*github.com/}"
+_url_pypi='https://pypi.org/project/mailman-rss'
license=('MIT')
-depends=('python-beautifulsoup4' 'python-dateutil' 'python-future' 'python-requests')
+depends=('python' 'python-beautifulsoup4' 'python-dateutil' 'python-future' 'python-requests')
makedepends=('python-setuptools')
optdepends=('python-twitter: twitter bot functionality')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- "${pkgname}-${pkgver}-LICENSE::${_rawurl}/master/LICENSE")
+ "${pkgname}-license-${_commit_license}::${url}/raw/${_commit_license}/LICENSE")
sha256sums=('0030e2ba55cf77b96d8777956270909cc68b77a7d5314093ea4f7909ce8c39af'
- 'SKIP')
+ '27d5c197628d3e10c3f9cb2bf6c1a9d8049834e633bb0ead3cb783418823cbbe')
build() {
cd "${pkgname}-${pkgver}"
@@ -22,10 +25,10 @@ build() {
}
package() {
- install -Dm644 "${pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dvm644 "${pkgname}-license-${_commit_license}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
cd "${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 'README.rst' "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+ install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
}
# vim: ts=2 sw=2 et: