summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Andersson2017-11-19 01:17:25 +0100
committerMaxim Andersson2017-11-19 01:17:25 +0100
commit68868371794ddbdc6e3968ba638ee01a65677881 (patch)
tree4d887835108c845aa8fcfc252f40569857342486
parentad115cb3ebd282180723030f28b2100fe0feb4c7 (diff)
downloadaur-68868371794ddbdc6e3968ba638ee01a65677881.tar.gz
Update to 1.0.0rc1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 23 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92aa88648465..c00dfca0a574 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,28 @@
+# Generated by mksrcinfo v8
+# Sun Nov 19 00:14:24 UTC 2017
pkgbase = mailpile
pkgdesc = A modern, fast web-mail client with user-friendly encryption and privacy features.
- pkgver = 0.5.2
- pkgrel = 3
+ pkgver = 1.0.0rc1
+ pkgrel = 1
url = http://www.mailpile.is
install = mailpile.install
arch = any
license = AGPL3
- depends = gnupg1
+ depends = gnupg
+ depends = python2-appdirs
+ depends = python2-cryptography
depends = python2-jinja>=2.6
depends = python2-lxml>=2.3.2
depends = python2-markupsafe
+ depends = python2-pbr
depends = python2-pgpdump
depends = python2-pillow
depends = python2-pydns
+ depends = python2-setuptools
depends = spambayes>=1.1a6
- source = https://github.com/pagekite/mailpile/archive/0.5.2.tar.gz
+ source = mailpile-1.0.0rc1.zip::https://github.com/mailpile/Mailpile/archive/88ae8e5831dddc628c827c44224166dbdbed91f1.zip
source = mailpile.service
- sha256sums = 2619dd0711628e25e216bec196d42381e50d45d943a727177f11f8ce89e26004
+ sha256sums = 7eeb45c261341dce5b3d56fecd1799825fc914b5a4392a3cbcc0c4b53c00fae5
sha256sums = 07adbd61cda225bf11818d39776240ee1077a3f2ddc9e5ef0f11825dd4ca504d
pkgname = mailpile
diff --git a/PKGBUILD b/PKGBUILD
index bb3626bb2725..0e5b9832551d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,50 +3,41 @@
# Contributor: cornholio <vigo.the.unholy.carpathian@gmail.com>
pkgname=mailpile
-pkgver=0.5.2
-pkgrel=3
+pkgver=1.0.0rc1
+pkgrel=1
pkgdesc="A modern, fast web-mail client with user-friendly encryption and privacy features."
arch=('any')
url="http://www.mailpile.is"
license=('AGPL3')
-depends=('gnupg1' 'python2-jinja>=2.6' 'python2-lxml>=2.3.2' 'python2-markupsafe' 'python2-pgpdump' 'python2-pillow' 'python2-pydns' 'spambayes>=1.1a6')
+depends=('gnupg' 'python2-appdirs' 'python2-cryptography' 'python2-jinja>=2.6' 'python2-lxml>=2.3.2' 'python2-markupsafe' 'python2-pbr' 'python2-pgpdump' 'python2-pillow' 'python2-pydns' 'python2-setuptools' 'spambayes>=1.1a6')
install=${pkgname}.install
-source=("https://github.com/pagekite/${pkgname}/archive/${pkgver}.tar.gz"
+source=("${pkgname}-${pkgver}.zip::https://github.com/mailpile/Mailpile/archive/88ae8e5831dddc628c827c44224166dbdbed91f1.zip"
+ #"https://github.com/mailpile/${pkgname}/archive/${pkgver}.tar.gz"
"${pkgname}.service")
-sha256sums=('2619dd0711628e25e216bec196d42381e50d45d943a727177f11f8ce89e26004'
+sha256sums=('7eeb45c261341dce5b3d56fecd1799825fc914b5a4392a3cbcc0c4b53c00fae5'
'07adbd61cda225bf11818d39776240ee1077a3f2ddc9e5ef0f11825dd4ca504d')
prepare() {
- cd "${srcdir}/Mailpile-${pkgver}"
+ cd "${srcdir}/Mailpile-"*
- # Set absolute paths for static files
- sed -i "s^('static/^('/usr/share/mailpile/static/^g" mailpile/config.py
- sed -i '/os.path.dirname( # scripts/d' mp
- sed -i 's^__file__))^"/usr/share/mailpile/mailpile")^g' mp
-
- # Use gnupg 1.4
- sed -i "s/gpg'/gpg1'/g" mailpile/crypto/gpgi.py
- sed -i "s/gpg /gpg1 /g" mailpile/plugins/crypto_gnupg.py
+ # Set absolute path
+ sed -i '5,9c mailpile_root = "/usr/share/mailpile"' mp
}
build() {
- cd "${srcdir}/Mailpile-${pkgver}"
+ cd "${srcdir}/Mailpile-"*
# Compile bytecode
python2 -m compileall -f mailpile
}
package() {
- cd "${srcdir}/Mailpile-${pkgver}"
+ cd "${srcdir}/Mailpile-"*
install -d "${pkgdir}/usr/share/${pkgname}"
- cp -r static "${pkgdir}/usr/share/${pkgname}/"
+ cp -r shared-data/* "${pkgdir}/usr/share/${pkgname}/"
cp -r mailpile "${pkgdir}/usr/share/${pkgname}/"
- cp -r locale "${pkgdir}/usr/share/${pkgname}/"
-
- find "${pkgdir}/usr/share/${pkgname}" -type f -exec chmod 644 '{}' ';'
- find "${pkgdir}/usr/share/${pkgname}" -type d -exec chmod 755 '{}' ';'
install -D mp -t "${pkgdir}/usr/bin"
install -Dm644 "../${pkgname}.service" -t "${pkgdir}/usr/lib/systemd/system"