summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik “Freso” S. Olesen2024-03-05 20:58:05 +0100
committerFrederik “Freso” S. Olesen2024-03-05 20:58:05 +0100
commit37664026b350ede6ff4a64fbd5047fd3be82de0c (patch)
tree2fc850a22c87e4d746a63c55983f2deed1bdf745
parent6d659ec6d47c1add33c5762ff13b04faa62cf5c3 (diff)
downloadaur-makepkg-tidy-upx-git.tar.gz
Split out upx tidy script into its own package
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD34
2 files changed, 27 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9eacf367a120..e247e911bcaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
-pkgbase = makepkg-tidy-scripts-git
- pkgdesc = Collection of scripts for tidying packages created using makepkg. Includes optipng and upx support.
- pkgver = 0.r7.4af5db2
+pkgbase = makepkg-tidy-upx-git
+ pkgdesc = Compress executables during packaging via a makepkg tidy script for UPX.
+ pkgver = r386.7878316
pkgrel = 1
- url = https://gitlab.com/Freso/makepkg-tidy-scripts
+ url = https://gitlab.archlinux.org/freso/makepkg-tidy-upx
arch = any
- license = GPL
+ license = GPL-2.0-or-later
makedepends = git
- optdepends = optipng: For optipng tidy script.
- optdepends = upx: For upx tidy script.
- provides = makepkg-tidy-scripts
+ makedepends = coreutils
+ provides = makepkg-tidy-upx
+ conflicts = makepkg-tidy-upx
conflicts = makepkg-tidy-scripts
- source = git+https://gitlab.com/Freso/makepkg-tidy-scripts
- md5sums = SKIP
-
-pkgname = makepkg-tidy-scripts-git
+ source = git+https://gitlab.archlinux.org/freso/makepkg-tidy-upx.git
+ b2sums = SKIP
+pkgname = makepkg-tidy-upx-git
+ depends = upx
+ depends = pacman
diff --git a/PKGBUILD b/PKGBUILD
index 68bb33a1079a..eb1c69b4658b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,23 @@
-# Maintainer: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
-_pkgname=makepkg-tidy-scripts
-pkgname=${_pkgname}-git
-pkgver=0.r7.4af5db2
+# Contributor: Frederik “Freso” S. Olesen <archlinux@freso.dk>
+pkgname=makepkg-tidy-upx-git
+pkgver=r386.7878316
pkgrel=1
-pkgdesc='Collection of scripts for tidying packages created using makepkg. Includes optipng and upx support.'
+pkgdesc='Compress executables during packaging via a makepkg tidy script for UPX.'
arch=('any')
-url='https://gitlab.com/Freso/makepkg-tidy-scripts'
-license=('GPL')
-makedepends=('git')
-optdepends=(
- 'optipng: For optipng tidy script.'
- 'upx: For upx tidy script.'
-)
+url="https://gitlab.archlinux.org/freso/${pkgname%-git}"
+license=('GPL-2.0-or-later')
+makedepends=('git' 'coreutils')
provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=("git+${url}")
-md5sums=('SKIP')
+conflicts=("${pkgname%-git}" 'makepkg-tidy-scripts')
+source=("git+${url}.git")
+b2sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
package() {
- cd "${_pkgname}"
- install -Dm755 optipng.sh "$pkgdir"/usr/share/makepkg/tidy/optipng.sh
- install -Dm755 upx.sh "$pkgdir"/usr/share/makepkg/tidy/upx.sh
+ depends=('upx' 'pacman')
+ install -Dm755 "${pkgname%-git}"/upx.sh "$pkgdir"/usr/share/makepkg/tidy/upx.sh
}