summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanwo2019-06-11 19:25:19 +0800
committerXuanwo2019-06-11 19:25:19 +0800
commit37a691c81b4da35af959e1e5f52387ba1ca4d623 (patch)
tree626df48aac8edc03a529ba2dc7a02c2785ea7fd8
downloadaur-makisu.tar.gz
Initiate commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63ba9eedc736
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = makisu
+ pkgdesc = Fast and flexible Docker image building tool, works in unprivileged containerized environments like Mesos and Kubernetes.
+ pkgver = 0.1.11
+ pkgrel = 1
+ url = https://github.com/uber/makisu
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ makedepends = make
+ makedepends = git
+ depends = glibc
+ provides = makisu
+ source = makisu-0.1.11.tar.gz::https://github.com/uber/makisu/archive/v0.1.11.tar.gz
+ sha256sums = 8d28948e0bf4f56693c836fd86d35e38c7a457206dd3f62386059f1741e4bac1
+
+pkgname = makisu
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dacef39ed29b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar
+*.gz
+*.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94e3bdc7d9b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Xuanwo <xuanwo@archlinuxcn.org>
+pkgname=makisu
+pkgver=0.1.11
+pkgrel=1
+pkgdesc='Fast and flexible Docker image building tool, works in unprivileged containerized environments like Mesos and Kubernetes.'
+depends=('glibc')
+makedepends=('go' 'make' 'git')
+arch=('x86_64')
+url='https://github.com/uber/makisu'
+license=('Apache')
+provides=('makisu')
+source=(makisu-${pkgver}.tar.gz::https://github.com/uber/makisu/archive/v${pkgver}.tar.gz)
+sha256sums=('8d28948e0bf4f56693c836fd86d35e38c7a457206dd3f62386059f1741e4bac1')
+
+build() {
+ export GOPATH="$srcdir/build"
+ export PATH=$GOPATH/bin:$PATH
+
+ cd $pkgname-${pkgver}
+
+ BUILD_LDFLAGS="-X ${pkgname}/lib/utils.BuildHash=v${pkgver}"
+
+ BUILD_LDFLAGS=$BUILD_LDFLAGS make bin/makisu/makisu
+}
+
+package() {
+ # Install binary
+ install -Dm755 "$srcdir/$pkgname-${pkgver}/bin/makisu/makisu" "$pkgdir/usr/bin/makisu"
+}
+
+# vim: ft=sh syn=sh et