summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorben Günther2021-02-18 14:03:23 +0100
committerThorben Günther2021-02-18 14:03:23 +0100
commit32c09211419f010611ca525d982926a2f1cc3bf2 (patch)
treeb6fa66c47cecd2ffc4493a05dbdc99f685b888b1
parentb37d95250a1b4e72e25ea642ad0d56658bbaec11 (diff)
downloadaur-mako-git.tar.gz
upgpkg: mako-git v1.4.1.r61.gdbd9c2b-1
Add systemd service and patch D-Bus.
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Fix-DBus-service.patch7
-rw-r--r--PKGBUILD17
-rw-r--r--mako.service15
4 files changed, 41 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 442488edab39..1c9c3686acb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mako-git
pkgdesc = Lightweight notification daemon for Wayland
- pkgver = v1.4.1.r51.g85d3d51
+ pkgver = v1.4.1.r61.gdbd9c2b
pkgrel = 1
url = http://mako-project.org
arch = x86_64
@@ -19,7 +19,11 @@ pkgbase = mako-git
provides = mako
conflicts = mako
source = mako::git+https://github.com/emersion/mako.git
+ source = mako.service
+ source = 0001-Fix-DBus-service.patch
sha1sums = SKIP
+ sha1sums = 688484d6bf677e6f6014c9311ff40fabae748bcc
+ sha1sums = 64b8a3446fa1ddc3d876629a0c4a3d1d6bb0b20f
pkgname = mako-git
diff --git a/0001-Fix-DBus-service.patch b/0001-Fix-DBus-service.patch
new file mode 100644
index 000000000000..aa007cc10d37
--- /dev/null
+++ b/0001-Fix-DBus-service.patch
@@ -0,0 +1,7 @@
+--- a/fr.emersion.mako.service.in
++++ b/fr.emersion.mako.service.in
+@@ -1,3 +1,4 @@
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=@bindir@/mako
++SystemdService=mako.service
diff --git a/PKGBUILD b/PKGBUILD
index 87941277be8e..0a69f503912b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Drew DeVault <sir@cmpwn.com>
pkgname=mako-git
_pkgname=mako
-pkgver=v1.4.1.r51.g85d3d51
+pkgver=v1.4.1.r61.gdbd9c2b
pkgrel=1
license=('MIT')
pkgdesc='Lightweight notification daemon for Wayland'
@@ -17,8 +17,14 @@ depends=(
optdepends=("jq: support for 'makoctl menu'")
arch=("x86_64")
url='http://mako-project.org'
-source=("${pkgname%-*}::git+https://github.com/emersion/mako.git")
-sha1sums=('SKIP')
+source=(
+ "${pkgname%-*}::git+https://github.com/emersion/mako.git"
+ "mako.service"
+ "0001-Fix-DBus-service.patch"
+)
+sha1sums=('SKIP'
+ '688484d6bf677e6f6014c9311ff40fabae748bcc'
+ '64b8a3446fa1ddc3d876629a0c4a3d1d6bb0b20f')
provides=('mako')
conflicts=('mako')
@@ -31,6 +37,10 @@ pkgver() {
)
}
+prepare() {
+ patch -Np1 -i "$srcdir/0001-Fix-DBus-service.patch" -d "$_pkgname"
+}
+
build() {
cd "$_pkgname"
arch-meson -Dzsh-completions=true -Dsd-bus-provider=libsystemd build
@@ -41,4 +51,5 @@ package() {
cd "$_pkgname"
DESTDIR="$pkgdir/" ninja -C build install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"${pkgname%-*}"/LICENSE
+ install -Dm0644 ../mako.service -t "$pkgdir"/usr/lib/systemd/user/
}
diff --git a/mako.service b/mako.service
new file mode 100644
index 000000000000..1c48492d9629
--- /dev/null
+++ b/mako.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Lightweight Wayland notification daemon
+Documentation=man:mako(1)
+PartOf=graphical-session.target
+After=graphical-session.target
+ConditionEnvironment=WAYLAND_DISPLAY
+
+[Service]
+Type=dbus
+BusName=org.freedesktop.Notifications
+ExecStart=/usr/bin/mako
+ExecReload=/usr/bin/makoctl reload
+
+[Install]
+WantedBy=graphical-session.target