summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrya2019-01-11 17:30:01 +0100
committertrya2019-01-11 17:33:29 +0100
commitcb9289d73375f1249a462183cedafd2845d0be0c (patch)
treecf6af9ef5e6fee7ff29a80aa5ab6fb5f97820ad4
downloadaur-mamepgui-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--COPYING14
-rw-r--r--PKGBUILD65
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cc79b726aaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Fri Jan 11 16:33:21 UTC 2019
+pkgbase = mamepgui-git
+ pkgdesc = Frontend for SDLMAME/SDLMESS based on MAME Plus!
+ pkgver = r37.2efd8b7
+ pkgrel = 1
+ url = http://sourceforge.net/projects/mameplus
+ arch = i686
+ arch = x86_64
+ license = custom:WTFPL
+ makedepends = git
+ depends = qt4
+ depends = quazip-qt4
+ optdepends = sdlmame: port of MAME/MESS using SDL
+ provides = mamepgui=1.6.0
+ conflicts = mamepgui
+ replaces = mamepgui-svn
+ source = mamepgui::git+https://github.com/svn2github/mamepgui.git
+ source = COPYING
+ md5sums = SKIP
+ md5sums = 389a9e29629d1f05e115f8f05c283df5
+
+pkgname = mamepgui-git
+
diff --git a/COPYING b/COPYING
new file mode 100644
index 000000000000..5a8e332545f6
--- /dev/null
+++ b/COPYING
@@ -0,0 +1,14 @@
+ DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
+ Version 2, December 2004
+
+ Copyright (C) 2004 Sam Hocevar <sam@hocevar.net>
+
+ Everyone is permitted to copy and distribute verbatim or modified
+ copies of this license document, and changing it is allowed as long
+ as the name is changed.
+
+ DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
+ TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+ 0. You just DO WHAT THE FUCK YOU WANT TO.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dff0865afe75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: trya <tryagainprod@gmail.com>
+
+pkgname=mamepgui-git
+pkgver=r37.2efd8b7
+pkgrel=1
+pkgdesc="Frontend for SDLMAME/SDLMESS based on MAME Plus!"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/mameplus"
+license=('custom:WTFPL')
+depends=('qt4' 'quazip-qt4')
+makedepends=('git')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}=1.6.0")
+replaces=("${pkgname%-git}-svn")
+optdepends=('sdlmame: port of MAME/MESS using SDL')
+source=('mamepgui::git+https://github.com/svn2github/mamepgui.git'
+ 'COPYING')
+md5sums=('SKIP'
+ '389a9e29629d1f05e115f8f05c283df5')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # disable static compilation and SDL 1.3 linking
+ sed -e 's|CONFIG += build_static|#CONFIG += build_static|' \
+ -e 's|CONFIG += build_sdl|#CONFIG += build_sdl|' \
+ -i common_settings.pri
+
+ # use included libraries instead of installed ones
+ sed -e 's|LIBS += -L./lib/$${OSDIR}|QMAKE_LIBDIR += ./lib/$${OSDIR}|' \
+ -e 's|LIBS += -lquazip -llzma|LIBS += -lquazip -llzma -lz|' \
+ -e 's|TARGETDEPS +=|#TARGETDEPS +=|' \
+ -e 's|./lib/$${OSDIR}/libquazip.a|#./lib/$${OSDIR}/libquazip.a|' \
+ -e 's|./lib/$${OSDIR}/liblzma.a|#./lib/$${OSDIR}/liblzma.a|' \
+ -i mamepgui.pro
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # build included liblzma.a (system one is not compatible)
+ cd lzma
+ qmake-qt4
+ make
+
+ # build mamepgui
+ cd ..
+ lrelease-qt4 mamepgui.pro
+ qmake-qt4
+ make
+}
+
+package() {
+ # install license
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+
+ # install executable
+ install -Dm755 "$srcdir/${pkgname%-git}/bin/mamepgui" "$pkgdir/usr/bin/mamepgui"
+}