summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrancoism902015-10-21 10:39:13 +0200
committerfrancoism902015-10-21 10:43:30 +0200
commit5cbe96748ad8b00b6303b559245844794836fd4b (patch)
tree7ca48cc8197e0a9b04d93f613b0f7a155eca8abb
parent62c96a2f4c66db74932213684df33ea2a972757d (diff)
downloadaur-5cbe96748ad8b00b6303b559245844794836fd4b.tar.gz
Update to 15.6.3-1
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE23
-rw-r--r--PKGBUILD15
3 files changed, 37 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70f8d8389e10..4d3a94d20821 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = manager-accounting
pkgdesc = Manager is free accounting software for small business
- pkgver = 15.5.86
+ pkgver = 15.6.3
pkgrel = 1
url = http://www.manager.io/
install = manager-accounting.install
@@ -13,12 +13,14 @@ pkgbase = manager-accounting
depends = gtk-sharp-2
depends = webkit-sharp
options = !makeflags
+ source = LICENSE
+ source = fix-path.patch
source = http://download.manager.io/version.txt
source = http://download.manager.io/manager-accounting.zip
- source = fix-path.patch
+ sha256sums = bd144763506372341487683b0f28ad627e7e8923ea8ef8569541b55f4b987061
+ sha256sums = 81e73bbae1a386dc76bd1f8b018868864c802cb242667d18b9d6f005518859f7
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 81e73bbae1a386dc76bd1f8b018868864c802cb242667d18b9d6f005518859f7
pkgname = manager-accounting
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ec6783c57380
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,23 @@
+End User License Agreement
+
+By using or distributing Manager Desktop Edition (referred to as „the software“), you indicate your acceptance of the following license terms:
+1. Usage
+
+NGSoftware grants you (the licensee) a permission to use the software at no cost, both for commercial and non-commercial purposes on any computer in your possession.
+2. Distribution
+
+You may distribute the software under the following conditions:
+
+ You may not modify, combine other commercial applications with, or otherwise prepare derivative works of the software.
+ You must not distribute the software in a manner, which arouses the impression that the software cannot be obtained for free or involves fees for its usage.
+ You must make reference to this licence (by URL, spoken word or as appropriate to the media used) on all copies of the software distributed.
+
+3. Warranties and Disclaimer
+
+The software and any support from NGSoftware are provided “AS IS” and without warranty, express or implied. NGSoftware specifically disclaim any implied warranties of merchantability and fitness for a particular purpose. In no event will NGSoftware be liable for any damages, including but not limited to any lost profits, lost savings or any incidental or consequential damages, whether resulting from impaired or lost data, software or computer failure or any other cause, or for any other claim by the user or for any third party claim.
+4. Limit of Liability
+
+Subject to any liability which may not be excluded or limited by law the licensor shall not be liable and hereby expressly excludes all liability for loss or damage howsoever and whenever caused to you.
+5. Termination
+
+The rights granted to you under this licence shall terminate automatically upon any breach by you of the terms of this licence. Individuals or entities who have received the software from you under this licence, however, will not have their licences terminated provided such individuals or entities remain in full compliance with those licences.
diff --git a/PKGBUILD b/PKGBUILD
index 05f0c92fa7c7..691ed4e7c8de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: François M. <francois5537 @ gmail.com>
pkgname=manager-accounting
-pkgver=15.5.86
+pkgver=15.6.3
pkgrel=1
pkgdesc='Manager is free accounting software for small business'
arch=('i686' 'x86_64')
@@ -11,12 +11,14 @@ depends=('mono' 'gtk2' 'gtk-sharp-2' 'webkit-sharp')
makedepends=('unzip')
install=manager-accounting.install
options=('!makeflags')
-source=("http://download.manager.io/version.txt"
- "http://download.manager.io/$pkgname.zip"
- "fix-path.patch")
-sha256sums=('SKIP'
+source=("LICENSE"
+ "fix-path.patch"
+ "http://download.manager.io/version.txt"
+ "http://download.manager.io/$pkgname.zip")
+sha256sums=('bd144763506372341487683b0f28ad627e7e8923ea8ef8569541b55f4b987061'
+ '81e73bbae1a386dc76bd1f8b018868864c802cb242667d18b9d6f005518859f7'
'SKIP'
- '81e73bbae1a386dc76bd1f8b018868864c802cb242667d18b9d6f005518859f7')
+ 'SKIP')
pkgver() {
cd "$srcdir"
@@ -45,4 +47,5 @@ package() {
cp -r usr/share/icons/* $pkgdir/usr/share/icons/
ln -s /usr/lib/manager-accounting/manager-accounting $pkgdir/usr/bin/manager-accounting
install -m644 usr/share/applications/$pkgname.desktop $pkgdir/usr/share/applications/
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}