summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPrashant Baid2023-01-14 17:53:35 +0530
committerPrashant Baid2023-01-14 17:53:35 +0530
commit09c8f891dbca5ce5b064c17e3279893726827afe (patch)
tree926fb1192588a16baeb6dc6ef6d75e8f8a496f9f
parentc28ae95509079ebf1f43c94eb371eba3c7aff427 (diff)
downloadaur-manga-cli-git.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD30
2 files changed, 26 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92c0840692d5..6d7c33afc4ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,19 @@
pkgbase = manga-cli-git
- pkgdesc = Bash script for reading mangas via the terminal by scraping manganato
- pkgver = r9.a1b7cff
+ pkgdesc = Manga Cli - script to read manga
+ pkgver = r49.7bdab0c
pkgrel = 1
- epoch = 1
- url = https://github.com/7USTIN/manga-cli
+ url = https://github.com/prsh11/manga-cli
arch = any
- license = GPL3
+ license = MIT
makedepends = git
- depends = coreutils
depends = curl
- depends = sed
- depends = awk
- depends = diffutils
- depends = patch
- depends = img2pdf
depends = zathura
- depends = zathura-pdf-mupdf
- source = git+https://github.com/7USTIN/manga-cli.git
+ depends = zathura-cb
+ depends = pup
+ optdepends = zathura-pdf-poppler: view manga file as pdf
+ optdepends = imagemagick: converting images to pdf
+ provides = manga-cli
+ source = git+https://github.com/prsh11/manga-cli
md5sums = SKIP
pkgname = manga-cli-git
diff --git a/PKGBUILD b/PKGBUILD
index db0ba55aa663..baaaa1f98225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
-# Maintainer: Nici <NicolasVontobel at protonmail dot com>
+# Maintainer : prsh11 (prashantbaid80@gmail.com)
pkgname='manga-cli-git'
_pkgname='manga-cli'
-pkgver=r9.a1b7cff
+pkgver=r49.7bdab0c
pkgrel=1
-epoch=1
-pkgdesc="Bash script for reading mangas via the terminal by scraping manganato"
+pkgdesc="Manga Cli - script to read manga"
arch=('any')
-url="https://github.com/7USTIN/manga-cli"
-license=('GPL3')
-depends=('coreutils' 'curl' 'sed' 'awk' 'diffutils' 'patch' 'img2pdf' 'zathura' 'zathura-pdf-mupdf')
-makedepends=('git')
-source=('git+https://github.com/7USTIN/manga-cli.git')
+url="https://github.com/prsh11/manga-cli"
+license=('MIT')
+depends=('curl' 'zathura' 'zathura-cb' 'pup')
+optdepends=('zathura-pdf-poppler: view manga file as pdf' 'imagemagick: converting images to pdf')
+makedepends=('git')
+provides=('manga-cli')
+source=("git+$url")
md5sums=('SKIP')
-
-pkgver() {
+pkgver()
+{
cd "$srcdir/${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package() {
- cd "$srcdir/$_pkgname"
+package()
+{
+ cd "$srcdir/$_pkgname"
install -Dm755 ./manga-cli "$pkgdir/usr/bin/manga-cli"
}