summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPrashant2022-03-05 16:28:54 +0530
committerPrashant2022-03-05 16:28:54 +0530
commitbdbbce44800edcfc9d6631b765740643a35faab8 (patch)
treecba60758d06bebe1ea452acbcd7300a4ddeca120
parent6909587ec34db37de93b441103032fa740b81a39 (diff)
downloadaur-manga-cli-notprash-git.tar.gz
Initial push
-rw-r--r--.SCRINFO20
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD56
-rw-r--r--windscribe-bin.install52
4 files changed, 40 insertions, 119 deletions
diff --git a/.SCRINFO b/.SCRINFO
deleted file mode 100644
index cb0e7f665206..000000000000
--- a/.SCRINFO
+++ /dev/null
@@ -1,20 +0,0 @@
-pkgbase = satania-buddy-git
- pkgdesc = Virtual Satania Desktop Assistant
- pkgver = r68.ade3a6f
- pkgrel = 1
- url = https://git.cianig.ga/monkeyballs/sataniabuddy
- arch = x86_64
- arch = i686
- license = AGPL
- makedepends = git
- makedepends = make
- makedepends = gcc
- depends = openmotif
- depends = cairo
- depends = xorg-server
- provides = satania-buddy
- conflicts = satania-buddy
- source = git+https://git.cianig.ga/monkeyballs/sataniabuddy
- md5sums = SKIP
-
-pkgname = satania-buddy-git
diff --git a/.SRCINFO b/.SRCINFO
index 021724411b7f..bac98a91a809 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
-pkgbase = pkgbase
- pkgdesc = Virtual Satania Desktop Assistant
- pkgver = r68.ade3a6f
+pkgbase = manga-cli-notprash-git
+ pkgdesc = Script to read manga from cli.
+ pkgver = r43.6f90d80
pkgrel = 1
- url = https://git.cianig.ga/monkeyballs/sataniabuddy
- arch = x86_64
- arch = i686
- license = AGPL
+ url = https://github.com/notprash/manga-cli.git
+ arch = any
+ license = MIT
makedepends = git
- makedepends = make
- makedepends = gcc
- depends = openmotif
- depends = cairo
- depends = xorg-server
- provides = satania-buddy
- conflicts = satania-buddy
- source = git+https://git.cianig.ga/monkeyballs/sataniabuddy
+ depends = curl
+ depends = zathura
+ depends = zathura-cb
+ depends = pup
+ optdepends = zathura-pdf-poppler: view manga file as pdf
+ optdepends = imagemagick: converting files to pdf
+ provides = manga-cli-notprash-git
+ source = git+https://github.com/notprash/manga-cli.git
md5sums = SKIP
-pkgname = satania-buddy-git
+pkgname = manga-cli-notprash-git
diff --git a/PKGBUILD b/PKGBUILD
index cd37207b1af4..2c8d7abacb4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,27 @@
-# Maintainer: monkeyballs <mydick@cunny.com>
-pkgname="satania-buddy-git"
-_pkgname="sataniabuddy"
-pkgver=r68.ade3a6f
-pkgrel=1
-pkgdesc="Virtual Satania Desktop Assistant"
-arch=("x86_64" "i686")
-url="https://git.cianig.ga/monkeyballs/sataniabuddy"
-license=('AGPL')
-depends=("openmotif" "cairo" "xorg-server")
-makedepends=("git" "make" "gcc")
-provides=("satania-buddy")
-conflicts=("satania-buddy")
-options=()
-source=(git+https://git.cianig.ga/monkeyballs/sataniabuddy)
-md5sums=('SKIP')
-prepare() {
- cd "$srcdir"/"$_pkgname"
- sed -i "s/AssetDirectory = \"\/usr\/local\/share\/satania\/assets\"/AssetDirectory = \"\/usr\/share\/satania\/assets\"/" main.c
-}
-build() {
- cd "$srcdir"/"$_pkgname"
- make
-}
-pkgver() {
- cd "$srcdir"/"$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-package() {
- cd "$srcdir"/"$_pkgname"
- make PREFIX="$pkgdir/usr" install
+pkgname='manga-cli-notprash-git'
+_pkgname='manga-cli'
+pkgver=r43.6f90d80
+pkgrel=1
+pkgdesc="Script to read manga from cli."
+arch=('any')
+url="https://github.com/notprash/manga-cli.git"
+license=('MIT')
+depends=('curl' 'zathura' 'zathura-cb' 'pup')
+makedepends=('git')
+optdepends=('zathura-pdf-poppler: view manga file as pdf' 'imagemagick: converting files to pdf')
+provides=('manga-cli-notprash-git')
+source=("git+$url")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 ./manga-cli "$pkgdir/usr/bin/manga-cli"
}
diff --git a/windscribe-bin.install b/windscribe-bin.install
deleted file mode 100644
index 252f0fa51bb3..000000000000
--- a/windscribe-bin.install
+++ /dev/null
@@ -1,52 +0,0 @@
-pre_install() {
-
- end=$((SECONDS+10))
-
- while :
- do
- if [ -z "$(ps -eo args | grep WindscribeEngine | grep -v grep)" ]; then
- break
- fi
-
- if [ $SECONDS -gt $end ]; then
- echo 'Error during Windscribe installation. WindscribeEngine is running. Please re-launch Windscribe. And try to update again.'
- exit 1
- fi
- done
-
- systemctl stop windscribe-helper > /dev/null 2>&1
- systemctl disable windscribe-helper > /dev/null 2>&1
-
- # Stop and disable firewalld service if it is active, otherwise it will conflict with iptables on OS reboot
- # Relevant for Fedora distributions
- systemctl is-active --quiet firewalld
- if [ $? -eq 0 ]
- then
- echo "Firewalld service is running. It will be stopped and disabled to avoid conflicts with the Windscribe iptables firewall."
- sudo systemctl stop firewalld
- sudo systemctl disable firewalld
- fi
-
- echo "Finish pre-install script"
-}
-
-post_install() {
- systemctl enable windscribe-helper
- systemctl start windscribe-helper
-
-}
-
-pre_upgrade() {
- set -e
- systemctl stop windscribe-helper
- systemctl disable windscribe-helper
-}
-
-post_upgrade() {
- post_install
-}
-
-pre_remove() {
- systemctl stop windscribe-helper
- systemctl disable windscribe-helper
-}