summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMads Mogensen2021-08-10 13:38:49 +0200
committerMads Mogensen2021-08-10 13:38:49 +0200
commitda90722145a50730bf7e5d81d514492d690ce828 (patch)
treeabdce0f2bfe930a983884bba4a25002ff15eb80a
downloadaur-maple2021.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--Maplesoft-x-maple-worksheet.xml11
-rw-r--r--PKGBUILD48
-rw-r--r--maple2021.desktop12
-rw-r--r--maple2021.install7
5 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b622e20ec10f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = maple2021
+ pkgdesc = A commercial computer algebra system developed and sold commercially by Maplesoft. Version 2021.
+ pkgver = latest
+ pkgrel = 1
+ url = https://www.maplesoft.com/download/
+ install = maple2021.install
+ arch = x86_64
+ license = custom
+ depends = ld-lsb
+ conflicts = maple18
+ conflicts = maple2019
+ conflicts = maple2020
+ options = !strip
+ source = maple2021.desktop
+ source = Maplesoft-x-maple-worksheet.xml
+ source = local://Maple2021.1LinuxX64Installer.run
+ sha256sums = f5dc3735d44e7db229a73d60752932fc86160c06e5d67e5d50bbfe9ca45ecf52
+ sha256sums = e29ded05d8cda39ae2c8dd2b204c3b47e5c432d75d8e2bde3ddae0b71136b643
+ sha256sums = e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
+
+pkgname = maple2021
diff --git a/Maplesoft-x-maple-worksheet.xml b/Maplesoft-x-maple-worksheet.xml
new file mode 100644
index 000000000000..d84353874362
--- /dev/null
+++ b/Maplesoft-x-maple-worksheet.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="application/x-maple-worksheet">
+ <comment>Maple Worksheet</comment>
+ <glob pattern="*.mw"/>
+ <glob pattern="*.mwz"/>
+ <glob pattern="*.mla"/>
+ <glob pattern="*.maple"/>
+ <glob pattern="*.mws"/>
+ </mime-type>
+</mime-info>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4ec0f820467
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Mads Mogensen <mads256h at gmail dot com>
+# Contributor: Alice Ryhl <alice at ryhl dot io>
+# Contributor: Mark Weiman <mark dot weiman at markzz dot com>
+
+# Based on Alice Ryhls maple2019 package
+
+# A valid license to Maple is required and you must have the installer ready.
+
+pkgname=maple2021
+pkgver=latest
+pkgrel=1
+pkgdesc="A commercial computer algebra system developed and sold commercially by Maplesoft. Version 2021."
+arch=('x86_64')
+url=https://www.maplesoft.com/download/
+license=('custom')
+depends=('ld-lsb')
+conflicts=(maple18 maple2019 maple2020)
+options=(!strip)
+install='maple2021.install'
+source=(maple2021.desktop Maplesoft-x-maple-worksheet.xml local://Maple2021.1LinuxX64Installer.run)
+sha256sums=('f5dc3735d44e7db229a73d60752932fc86160c06e5d67e5d50bbfe9ca45ecf52'
+ 'e29ded05d8cda39ae2c8dd2b204c3b47e5c432d75d8e2bde3ddae0b71136b643'
+ 'SKIP')
+
+build() {
+ echo "Unpacking installer... If the installation fails make sure your /tmp directory is not full"
+ "${srcdir}/Maple2021.1LinuxX64Installer.run" --mode unattended --installdir "${srcdir}/maple2021" --desktopshortcut 0 --defaultapp 0
+}
+
+package () {
+ install -d "${pkgdir}/usr/bin/"
+ install -d "${pkgdir}/usr/share/licenses/maple2021/"
+ install -D -m755 "${srcdir}/maple2021.desktop" "${pkgdir}/usr/share/applications/maple2021.desktop"
+ install -D -m755 "${srcdir}/Maplesoft-x-maple-worksheet.xml" "${pkgdir}/usr/share/mime/packages/Maplesoft-x-maple-worksheet.xml"
+
+ cp -r "${srcdir}/maple2021/man" "${pkgdir}/usr/share/"
+ cp -r "${srcdir}/maple2021" "${pkgdir}/usr/share/"
+
+ ln -s "/usr/share/maple2021/bin/maple" "${pkgdir}/usr/bin/maple"
+ ln -s "/usr/share/maple2021/bin/xmaple" "${pkgdir}/usr/bin/xmaple"
+ ln -s "/usr/share/maple2021/bin/maple.system.type" "${pkgdir}/usr/bin/maple.system.type"
+ ln -s "/usr/share/maple2021/bin/mint" "${pkgdir}/usr/bin/mint"
+ ln -s "/usr/share/maple2021/EULA.html" "${pkgdir}/usr/share/licenses/maple2021/LICENSE.html"
+
+ find "${pkgdir}/" -name "*.log" -delete
+ find "${pkgdir}/" -type f -exec sed -i "s|${srcdir}|/usr/share|g" {} \;
+}
+
diff --git a/maple2021.desktop b/maple2021.desktop
new file mode 100644
index 000000000000..1a94b2f8a07c
--- /dev/null
+++ b/maple2021.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=Maple 2021
+Type=Application
+Comment=Maple 2021
+Exec=/usr/share/maple2021/bin/xmaple %f
+Terminal=false
+Icon=/usr/share/maple2021/bin/Maple2021.png
+GenericName=Maple
+Categories=Applications;Education;Mathematics;
+MimeType=application/x-maple-worksheet;
diff --git a/maple2021.install b/maple2021.install
new file mode 100644
index 000000000000..a9f3ab5275c4
--- /dev/null
+++ b/maple2021.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "Run /usr/share/maple2021/bin/activation to activate your maple license."
+}
+
+post_upgrade() {
+ echo "Upgrading maple. Run /usr/share/maple2021/bin/activation if you need to reactivate your maple license."
+}