summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-03-19 10:34:08 +0000
committerxiota2024-03-19 10:34:08 +0000
commit96df78ad1ad0d1be9644c47d1e4d7f891b07e51f (patch)
tree6c67d5c6103fc05f76b3a4434d2a21f24915e99f
parent0a402506bd2f327d4a2233de45551a34cede071b (diff)
downloadaur-maplibre-native-git.tar.gz
revert to qt5
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 210100eb9710..1b72e144b34d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,8 +15,8 @@ pkgbase = maplibre-native-git
makedepends = git
makedepends = glfw
makedepends = libwebp
- depends = qt6-base
- depends = qt6-location
+ depends = qt5-base
+ depends = qt5-location
provides = maplibre-native
conflicts = maplibre-native
source = maplibre.maplibre-native-qt::git+https://github.com/maplibre/maplibre-native-qt.git
diff --git a/PKGBUILD b/PKGBUILD
index ec193b246aea..5edd1da2a77d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
# options
#: ${_gcc_version:=12}
+: ${_qt_version:=5}
: ${_build_git:=true}
@@ -27,8 +28,8 @@ license=(
# main package
_main_package() {
depends=(
- 'qt6-base'
- 'qt6-location'
+ "qt${_qt_version:-5}-base"
+ "qt${_qt_version:-5}-location"
)
makedepends=(
"gcc${_gcc_version:-}"