summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Lisowski2021-05-16 13:14:56 +0200
committerMichał Lisowski2021-05-16 13:14:56 +0200
commit40e62b097c28d0068a957aa9ac23a0d9d9dbcd70 (patch)
tree90ecf69bdbf845272d03ad6c43cb5832ecc44aa8
parent683a9e554b9dc80c13e3297594a66db7a7b1b420 (diff)
downloadaur-maszyna-git.tar.gz
Update assets to 2104, fix c++ format errors
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
-rw-r--r--format.patch90
3 files changed, 107 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 613f28f99e8f..4e463715cb70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,18 +20,20 @@ pkgbase = maszyna-git
depends = openvr
depends = python2
depends = wine
- noextract = MaSzyna2009.zip
- noextract = 2009HF.zip
+ noextract = MaSzyna2104.zip
+ noextract = 2104HF.zip
source = maszyna-git::git+https://github.com/eu07/maszyna.git
- source = http://stuff.eu07.pl/MaSzyna2009.zip
- source = http://stuff.eu07.pl/2009HF.zip
+ source = http://stuff.eu07.pl/MaSzyna2104.zip
+ source = http://stuff.eu07.pl/2104HF.zip
source = https://eu07.pl/theme/Maszyna/dokumentacja/inne/readme_pliki/licencja.html
source = maszyna.sh
+ source = format.patch
md5sums = SKIP
- md5sums = 009a039e320592cf30f11ee07c8237e9
- md5sums = c77ac9dea108545ec5dea76d896f083a
+ md5sums = 125b037d69729ab67091cf757040b277
+ md5sums = 1362073d9fc81b83e9970f02c38b0257
md5sums = fdbde83abd66899b540800c3d4b5f0a2
md5sums = a24521953418278dc07571bf3ee75b89
+ md5sums = d33171fc3bc9a9ddc3e2b63ab208055a
pkgname = maszyna-git
diff --git a/PKGBUILD b/PKGBUILD
index d40074a512ba..eb41eee88f66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Michał Lisowski <lisu@riseup.net>
-_assets_ver=2009
+_assets_ver=2104
pkgname=maszyna-git
pkgver=r2131.2376aa6f
@@ -15,14 +15,16 @@ source=("$pkgname"::'git+https://github.com/eu07/maszyna.git'
"http://stuff.eu07.pl/MaSzyna${_assets_ver}.zip"
"http://stuff.eu07.pl/${_assets_ver}HF.zip"
"https://eu07.pl/theme/Maszyna/dokumentacja/inne/readme_pliki/licencja.html"
- "maszyna.sh")
+ "maszyna.sh"
+ "format.patch")
noextract=("MaSzyna${_assets_ver}.zip"
"${_assets_ver}HF.zip")
md5sums=('SKIP'
- '009a039e320592cf30f11ee07c8237e9'
- 'c77ac9dea108545ec5dea76d896f083a'
+ '125b037d69729ab67091cf757040b277'
+ '1362073d9fc81b83e9970f02c38b0257'
'fdbde83abd66899b540800c3d4b5f0a2'
- 'a24521953418278dc07571bf3ee75b89')
+ 'a24521953418278dc07571bf3ee75b89'
+ 'd33171fc3bc9a9ddc3e2b63ab208055a')
pkgver() {
cd "$srcdir/$pkgname"
@@ -31,6 +33,8 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
+
+ patch -p1 -i "${srcdir}/format.patch"
}
build() {
diff --git a/format.patch b/format.patch
new file mode 100644
index 000000000000..77621fc2e8ed
--- /dev/null
+++ b/format.patch
@@ -0,0 +1,90 @@
+--- maszyna-git/uilayer.cpp.orig 2021-05-16 12:34:23.252270339 +0200
++++ maszyna-git/uilayer.cpp 2021-05-16 12:35:13.731806238 +0200
+@@ -25,6 +25,12 @@
+ #include "imgui/imgui_impl_opengl3.h"
+ #endif
+
++#if defined(__clang__)
++#pragma clang diagnostic ignored "-Wformat-security" // warning : warning: format string is not a string literal
++#elif defined(__GNUC__)
++#pragma GCC diagnostic ignored "-Wformat-security" // warning : format string is not a string literal (potentially insecure)
++#endif
++
+ GLFWwindow *ui_layer::m_window{nullptr};
+ ImGuiIO *ui_layer::m_imguiio{nullptr};
+ GLint ui_layer::m_textureunit { GL_TEXTURE0 };
+--- maszyna-git/application.cpp.orig 2021-05-16 12:37:55.990633115 +0200
++++ maszyna-git/application.cpp 2021-05-16 12:38:27.260144689 +0200
+@@ -43,6 +43,12 @@
+ #include <sys/stat.h>
+ #endif
+
++#if defined(__clang__)
++#pragma clang diagnostic ignored "-Wformat-security" // warning : warning: format string is not a string literal
++#elif defined(__GNUC__)
++#pragma GCC diagnostic ignored "-Wformat-security" // warning : format string is not a string literal (potentially insecure)
++#endif
++
+ eu07_application Application;
+ screenshot_manager screenshot_man;
+
+--- maszyna-git/driveruipanels.cpp.orig 2021-05-16 12:38:52.009808832 +0200
++++ maszyna-git/driveruipanels.cpp 2021-05-16 12:39:06.919624454 +0200
+@@ -31,6 +31,12 @@
+ #include "Logs.h"
+ #include "widgets/vehicleparams.h"
+
++#if defined(__clang__)
++#pragma clang diagnostic ignored "-Wformat-security" // warning : warning: format string is not a string literal
++#elif defined(__GNUC__)
++#pragma GCC diagnostic ignored "-Wformat-security" // warning : format string is not a string literal (potentially insecure)
++#endif
++
+ void
+ drivingaid_panel::update() {
+
+--- maszyna-git/editoruipanels.cpp.orig 2021-05-16 12:39:29.799363787 +0200
++++ maszyna-git/editoruipanels.cpp 2021-05-16 12:39:42.159232809 +0200
+@@ -20,6 +20,12 @@
+ #include "renderer.h"
+ #include "utilities.h"
+
++#if defined(__clang__)
++#pragma clang diagnostic ignored "-Wformat-security" // warning : warning: format string is not a string literal
++#elif defined(__GNUC__)
++#pragma GCC diagnostic ignored "-Wformat-security" // warning : format string is not a string literal (potentially insecure)
++#endif
++
+ void
+ itemproperties_panel::update( scene::basic_node const *Node ) {
+ m_node = Node;
+--- maszyna-git/launcher/scenery_list.cpp.orig 2021-05-16 12:42:08.918017518 +0200
++++ maszyna-git/launcher/scenery_list.cpp 2021-05-16 12:42:21.287933461 +0200
+@@ -8,6 +8,12 @@
+ #include "Logs.h"
+ #include <filesystem>
+
++#if defined(__clang__)
++#pragma clang diagnostic ignored "-Wformat-security" // warning : warning: format string is not a string literal
++#elif defined(__GNUC__)
++#pragma GCC diagnostic ignored "-Wformat-security" // warning : format string is not a string literal (potentially insecure)
++#endif
++
+ ui::scenerylist_panel::scenerylist_panel(scenery_scanner &scanner)
+ : ui_panel(STR("Scenario list"), false), scanner(scanner), placeholder_mini("textures/mini/other")
+ {
+--- maszyna-git/launcher/keymapper.cpp.orig 2021-05-16 12:42:48.597753852 +0200
++++ maszyna-git/launcher/keymapper.cpp 2021-05-16 12:42:59.147686394 +0200
+@@ -2,6 +2,12 @@
+ #include "keymapper.h"
+ #include "simulation.h"
+
++#if defined(__clang__)
++#pragma clang diagnostic ignored "-Wformat-security" // warning : warning: format string is not a string literal
++#elif defined(__GNUC__)
++#pragma GCC diagnostic ignored "-Wformat-security" // warning : format string is not a string literal (potentially insecure)
++#endif
++
+ ui::keymapper_panel::keymapper_panel()
+ : ui_panel(STR("Keymapper"), false)
+ {