summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-11-14 17:18:14 -0800
committerxiota2023-11-14 17:19:07 -0800
commit958a90fe10e5cdd2b5046daddba1d48bc007912d (patch)
tree9b88ffdbdfca552e4a8b7581b0df01f3d19a2cbf
parent04e9d5fc69ec17161510cc6d3687bb735afcd442 (diff)
downloadaur-material-kwin-decoration-git.tar.gz
update depends, etc
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD76
3 files changed, 69 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79bf8908c2db..a813f4880dcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = material-kwin-decoration-git
- pkgdesc = Material-ish window decoration theme for KWin, with LIM support.
- pkgver = v5+38+g65fe6f5
+ pkgdesc = Material-ish window decoration theme for KWin, with LIM support
+ pkgver = 0.0.7.r39.g0e989e5
pkgrel = 1
url = https://github.com/Zren/material-decoration
arch = x86_64
license = GPL
- makedepends = git
makedepends = cmake
makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = kwayland5
+ depends = kconfig5
+ depends = kconfigwidgets5
+ depends = kcoreaddons5
depends = kdecoration
- depends = kconfig
- depends = kconfigwidgets
- depends = kcoreaddons
- depends = kiconthemes
- depends = kwindowsystem
+ depends = kiconthemes5
+ depends = kwindowsystem5
optdepends = appmenu-gtk-module: gtk app support
provides = material-kwin-decoration
conflicts = material-kwin-decoration
@@ -21,4 +22,3 @@ pkgbase = material-kwin-decoration-git
sha256sums = SKIP
pkgname = material-kwin-decoration-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index ab324e908678..e52ee19c6550 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,72 @@
-# Maintainer: Zren <zrenfire@gmail.com>
+# Maintainer:
+# Contributor: Zren <zrenfire@gmail.com>
-_pkgname=material-kwin-decoration
-pkgname=${_pkgname}-git
-pkgver=v5+38+g65fe6f5
+_pkgname="material-kwin-decoration"
+pkgname="${_pkgname}-git"
+pkgver=0.0.7.r39.g0e989e5
pkgrel=1
-pkgdesc="Material-ish window decoration theme for KWin, with LIM support."
+pkgdesc="Material-ish window decoration theme for KWin, with LIM support"
url='https://github.com/Zren/material-decoration'
-arch=('x86_64')
license=('GPL')
-depends=('kdecoration' 'kconfig' 'kconfigwidgets' 'kcoreaddons' 'kiconthemes' 'kwindowsystem')
-makedepends=('git' 'cmake' 'extra-cmake-modules')
-optdepends=('appmenu-gtk-module: gtk app support')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source=("${_pkgname}::git+${url}.git")
+arch=('x86_64')
+
+depends=(
+ kconfig5
+ kconfigwidgets5
+ kcoreaddons5
+ kdecoration
+ kiconthemes5
+ kwindowsystem5
+
+ ## runtime?
+ #kauth5
+ #kcodecs5
+
+ ## implicit
+ #gcc-libs
+ #glibc
+ #kguiaddons5
+ #ki18n5
+ #kwidgetsaddons5
+ #libxcb
+ #qt5-base
+ #qt5-x11extras
+)
+makedepends=(
+ cmake
+ extra-cmake-modules
+ git
+ kwayland5
+)
+optdepends=(
+ 'appmenu-gtk-module: gtk app support'
+)
+
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+
+_pkgsrc="$_pkgname"
+source=("$_pkgsrc"::"git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git describe --tags --long | sed 's/-/+/g'
+ cd "$_pkgsrc"
+ git describe --long --tags --exclude='*[a-zA-Z][a-zA-Z]*' 2>/dev/null \
+ | sed -E 's/^v/0.0./;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cmake \
- -S "${srcdir}/${_pkgname}" \
- -B "build" \
+ local _cmake_options=(
+ -B build
+ -S "$_pkgsrc"
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ -Wno-dev
+ )
- make -C "build"
+ cmake "${_cmake_options[@]}"
+ cmake --build build
}
-
package() {
- make -C "build" DESTDIR="$pkgdir" install
+ DESTDIR="${pkgdir:?}" cmake --install build
}