summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam J. Bowman2018-05-03 10:14:50 -0400
committerWilliam J. Bowman2018-05-03 10:14:50 -0400
commit4e3d56caa3d1ad1c26b43978b6b51d3fcba72f77 (patch)
treee01f517b395d71771f7bcd60ad7d12c69415278a
parent799e255631690ebdd45a7e650e32761c8ada27a8 (diff)
downloadaur-4e3d56caa3d1ad1c26b43978b6b51d3fcba72f77.tar.gz
Updated to 1.7.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b15e2d5b811..48e65a7c30a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = mathcomp
pkgdesc = The entire mathematical components library for Coq.
- pkgver = 1.6.4
- pkgrel = 3
+ pkgver = 1.7.0
+ pkgrel = 1
url = https://math-comp.github.io/math-comp/
arch = i686
arch = x86_64
license = GPL
- depends = coq>=8.5
+ depends = coq>=8.6
depends = coq<=8.8
- source = mathcomp-1.6.4.tar.gz::https://github.com/math-comp/math-comp/tarball/mathcomp-1.6.4
- sha256sums = 8595c208ed1f5589552de498ef2c043b577228bd3c048775fa51cea90c603adb
- sha512sums = 972cbaf36653ea30c77c876095bac8aa779b36fa18f0c7f753933569fe8e9663cd57c1b4e49cbe5cbdb1cadf1415b57426d4ecbe318d1e24b2a3b5966fe194a6
+ source = mathcomp-1.7.0.tar.gz::https://github.com/math-comp/math-comp/tarball/mathcomp-1.7.0
+ sha256sums = 2d30a244769f3c7d628bff2f9118df935cd99dad774842b0e9d35bafdb3e02ea
+ sha512sums = 332f79e97cc3a0fe72cff7e96080c34d5de11ff2c86bf1f4ed4953457cb3cd36795502e4fed24dec698492419076acd97571c154d946ba91b02ad27389423a61
pkgname = mathcomp
diff --git a/PKGBUILD b/PKGBUILD
index 809731a825dd..4b0e70b5c3a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: William J. Bowman <aur@williamjbowman.com>
pkgname=mathcomp
-pkgver=1.6.4
-pkgrel=3
+pkgver=1.7.0
+pkgrel=1
+# sigh. they rename the folder based on the commit hash, and glob matching can cause errors
+_pkgcommitid=591c3e4
pkgdesc="The entire mathematical components library for Coq."
url="https://math-comp.github.io/math-comp/"
arch=('i686' 'x86_64')
license=('GPL')
-depends=('coq>=8.5' 'coq<=8.8') # Works with 8.4pl6, 8.5pl3, 8.6.0, and 8.7 but don't quite know how to say that
+depends=('coq>=8.6' 'coq<=8.8')
source=(mathcomp-$pkgver.tar.gz::https://github.com/math-comp/math-comp/tarball/mathcomp-$pkgver)
-sha256sums=('8595c208ed1f5589552de498ef2c043b577228bd3c048775fa51cea90c603adb')
-sha512sums=('972cbaf36653ea30c77c876095bac8aa779b36fa18f0c7f753933569fe8e9663cd57c1b4e49cbe5cbdb1cadf1415b57426d4ecbe318d1e24b2a3b5966fe194a6')
+sha256sums=('2d30a244769f3c7d628bff2f9118df935cd99dad774842b0e9d35bafdb3e02ea')
+sha512sums=('332f79e97cc3a0fe72cff7e96080c34d5de11ff2c86bf1f4ed4953457cb3cd36795502e4fed24dec698492419076acd97571c154d946ba91b02ad27389423a61')
build() {
- cd $srcdir/math-comp-math-comp-*/$pkgname
+ cd $srcdir/math-comp-math-comp-${_pkgcommitid}/$pkgname
# Per recommendations from README, use -j 3
make -j 3
}
package(){
- cd $srcdir/math-comp-math-comp-*/$pkgname
- echo 'COQMF_WINDRIVE=' > Makefile.coq.local
+ cd $srcdir/math-comp-math-comp-${_pkgcommitid}/$pkgname
make DSTROOT="${pkgdir}" install
}