aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBatuhan Başerdem2020-09-25 15:43:53 -0400
committerBatuhan Başerdem2020-09-25 15:43:53 -0400
commitb4a092852d00679b1afc833329ae8b89e1a07e3a (patch)
tree515187d71884af6a707532f27d51a93cd69f4ac2
parent1d4947197b9bb6c04695f7280e7b969ee7c12d72 (diff)
downloadaur-b4a092852d00679b1afc833329ae8b89e1a07e3a.tar.gz
Added mesa fix
-rw-r--r--PKGBUILD3
-rw-r--r--README.md2
2 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1a8ea07c5d2..540cc45a92a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -142,8 +142,7 @@ prepare() {
--pkgdesc "${pkgdesc}" \
--categories "Development;Education;Science;Mathematics;IDE" \
--mimetypes "application/x-matlab-data;text/x-matlab" \
- --exec 'matlab -desktop'
- #--exec 'sh -c '\''if [ "${MATLAB_INTEL_OVERRIDE}" = "yes" ] ; then exec env MESA_LOADER_DRIVER_OVERRIDE=i965 matlab -desktop ; else exec matlab -desktop ; fi'\'
+ --exec 'sh -c '\''if [ "${MATLAB_INTEL_OVERRIDE}" = "yes" ] ; then exec env MESA_LOADER_DRIVER_OVERRIDE=i965 matlab -desktop ; else exec matlab -desktop ; fi'\'
}
build() {
diff --git a/README.md b/README.md
index b914afa0520f..a3dd357eb66f 100644
--- a/README.md
+++ b/README.md
@@ -13,6 +13,8 @@ exclude this package from your workflow.
(Partial install is around 8 GB; and full install about 16 GB)
* Turn off compression if this package will only be installed on the build machine;
this cuts a fair amount of time from the build and compression is unneccessary on local machines.
+* Set `MATLAB_INTEL_OVERRIDE='yes'` in your environment if hardware acceleration
+does not work on your Intel GPU.
# Requirements