aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButui Hu2019-05-03 10:20:07 +0800
committerButui Hu2019-05-03 10:20:07 +0800
commiteeeb8dea7cdf7256a0d916f638fe3a7f1cb05f93 (patch)
treef8fab7098420e512a57eb168c4a5d6e8ca3bce9c
parentda02d2ce1b2266c699b7f88237d775728e1edad5 (diff)
downloadaur-eeeb8dea7cdf7256a0d916f638fe3a7f1cb05f93.tar.gz
bump version to 9.6.0.1072779
Now, CJK font display works without dirty hack
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a2accdcd664..18bee19de7b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = matlab
pkgdesc = A high-level language for numerical computation and visualization
- pkgver = 9.5.0.944444
+ pkgver = 9.6.0.1072779
pkgrel = 1
url = http://www.mathworks.com
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b7cdc0f0fef6..a97c0b934d0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,7 +44,7 @@ _partialinstall=false
pkgname=matlab
# install dir
_instdir="/opt/${pkgname}"
-pkgver=9.5.0.944444
+pkgver=9.6.0.1072779
pkgrel=1
pkgdesc='A high-level language for numerical computation and visualization'
arch=('x86_64')
@@ -73,40 +73,38 @@ source=("local:///matlab.tar"
"local:///matlab.fik"
"matlab.png::https://upload.wikimedia.org/wikipedia/commons/2/21/Matlab_Logo.png")
md5sums=("SKIP" "SKIP" 'cf28632239db6e02bc09bcca6bf5360f')
-#PKGEXT='.pkg.tar'
+PKGEXT='.pkg.tar'
prepare() {
- # using system's libstdc++
- # using system's libfreetype for CJK font
msg2 'Creating desktop file'
gendesk -f -n --pkgname "${pkgname}" \
--pkgdesc "${pkgdesc}" \
--categories "Development;Education;Science;Mathematics;IDE" \
- --exec 'env LD_PRELOAD=/usr/lib/libfreetype.so.6:/usr/lib/libstdc++.so.6 /opt/matlab/bin/matlab -desktop'
+ --exec '/opt/matlab/bin/matlab -desktop'
msg2 'Extracting file installation key'
_fik=$(grep -o [0-9-]* ${pkgname}.fik)
msg2 'Modifying the installer settings'
- sed -i "s,^# destinationFolder=,destinationFolder=${pkgdir}/${_instdir}," "${srcdir}/installer_input.txt"
- sed -i "s,^# agreeToLicense=,agreeToLicense=yes," "${srcdir}/installer_input.txt"
- sed -i "s,^# mode=,mode=silent," "${srcdir}/installer_input.txt"
- sed -i "s,^# fileInstallationKey=,fileInstallationKey=${_fik}," "${srcdir}/installer_input.txt"
+ sed -i "s,^# destinationFolder=,destinationFolder=${pkgdir}/${_instdir}," "${srcdir}/${pkgname}/installer_input.txt"
+ sed -i "s,^# agreeToLicense=,agreeToLicense=yes," "${srcdir}/${pkgname}/installer_input.txt"
+ sed -i "s,^# mode=,mode=silent," "${srcdir}/${pkgname}/installer_input.txt"
+ sed -i "s,^# fileInstallationKey=,fileInstallationKey=${_fik}," "${srcdir}/${pkgname}/installer_input.txt"
if [ ! -z ${_products+isSet} ]; then
msg2 'Building a package with a subset of the licensed products.'
for _product in "${_products[@]}"; do
- sed -i "/^#product.${_product}$/ s/^#//" "${srcdir}/installer_input.txt"
+ sed -i "/^#product.${_product}$/ s/^#//" "${srcdir}/${pkgname}/installer_input.txt"
done
fi
}
package() {
msg2 'Starting MATLAB installer'
- "${srcdir}/install" -inputFile "${srcdir}/installer_input.txt"
+ "${srcdir}/${pkgname}/install" -inputFile "${srcdir}/${pkgname}/installer_input.txt"
msg2 'Installing license'
- install -D -m644 "${srcdir}/license_agreement.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 "${srcdir}/${pkgname}/license_agreement.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
msg2 'Installing desktop files'
install -D -m644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"