summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriel Lieberman2018-10-05 17:36:04 +0300
committerAriel Lieberman2018-10-05 17:36:04 +0300
commit41e43e265a1a91acdb82bd30e30e39c5498da398 (patch)
tree07a62229c9ef83376861a2de9c99e5da9ab97761
parentbb75eb1a85d609171c2bac461869fffe27c2795f (diff)
downloadaur-41e43e265a1a91acdb82bd30e30e39c5498da398.tar.gz
desktop file adds system glib's to env
see https://wiki.archlinux.org/index.php/Matlab#Addon_manager_not_working for more informaiton
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b135c04e3fa6..4cddc736a0b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = matlab-support
pkgdesc = Provides dependencies desktop file and common fixes for MATLAB.
pkgver = 9.5.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.mathworks.com
arch = x86_64
license = custom
@@ -22,6 +22,7 @@ pkgbase = matlab-support
depends = qt5-x11extras
depends = xerces-c
optdepends = gcc6: For MEX support
+ optdepends = libselinux: for Addon manager support
provides = matlab
conflicts = matlab
source = https://upload.wikimedia.org/wikipedia/commons/2/21/Matlab_Logo.png
diff --git a/PKGBUILD b/PKGBUILD
index d84747cdb86b..44d5cd6cee03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@
pkgname=matlab-support
pkgver=9.5.0
-pkgrel=2
+pkgrel=3
pkgdesc='Provides dependencies desktop file and common fixes for MATLAB.'
arch=('x86_64')
url='http://www.mathworks.com'
@@ -44,7 +44,8 @@ depends=('gconf'
'qt5-websockets'
'qt5-x11extras'
'xerces-c')
-optdepends=('gcc6: For MEX support')
+optdepends=('gcc6: For MEX support'
+ 'libselinux: for Addon manager support')
makedepends=('gendesk')
provides=('matlab')
conflicts=('matlab')
@@ -52,11 +53,14 @@ source=('https://upload.wikimedia.org/wikipedia/commons/2/21/Matlab_Logo.png')
sha512sums=('ba72458379c89b22a27d1d7e357cefae4437fa28caac47b26ccd4f5b01b8cbc2c000baf38b5a52565f29b14e6da922bc3dc14bc5d47fa682fb6871422a59c397')
prepare() {
+ # desktop file links matlab to system glib's as opposed to the ones shipped with matlab
+ # see https://wiki.archlinux.org/index.php/Matlab#Addon_manager_not_working for more info
+
msg2 'Creating desktop file'
gendesk -f -n --pkgname 'matlab' \
--pkgdesc 'A high-level language for numerical computation and visualization.' \
--categories 'Development;Education;science;Mathematics;IDE' \
- --exec 'env LD_PRELOAD=/usr/lib/libfreetype.so.6:/usr/lib/libstdc++.so.6 matlab -desktop' \
+ --exec 'env env LD_PRELOAD=/usr/lib/libfreetype.so.6:/usr/lib/libstdc++.so.6:/usr/lib/libgio-2.0.so:/usr/lib/libglib-2.0.so:/usr/lib/libgmodule-2.0.so:/usr/lib/libgobject-2.0.so:/usr/lib/libgthread-2.0.so matlab -desktop' \
--mimetypes 'text/x-matlab' \
"${srcdir}/matlab.desktop" >/dev/null
}