summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2018-11-28 08:50:48 +0100
committerWilliam Gathoye2018-11-29 21:25:39 +0100
commit6612156ad04080865270e6d254b321f0e326a808 (patch)
tree33e594ca7016df62091755804ff5869a7ce5dc04
parent6521440cf633124db72eb208905cdef757e38323 (diff)
downloadaur-6612156ad04080865270e6d254b321f0e326a808.tar.gz
Upgrade to 4.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
-rw-r--r--mattermost-package-json.patch76
3 files changed, 99 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac5403ac5e10..c661c24866ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mattermost-desktop
pkgdesc = Mattermost Desktop application for Linux (Beta)
- pkgver = 4.1.2
- pkgrel = 2
+ pkgver = 4.2.0
+ pkgrel = 1
url = https://github.com/mattermost/desktop
arch = i686
arch = x86_64
@@ -9,12 +9,14 @@ pkgbase = mattermost-desktop
makedepends = npm
makedepends = git
depends = electron
- source = mattermost-desktop-4.1.2.tar.gz::https://github.com/mattermost/desktop/archive/v4.1.2.tar.gz
+ source = mattermost-desktop-4.2.0.tar.gz::https://github.com/mattermost/desktop/archive/v4.2.0.tar.gz
source = mattermost-desktop.sh
source = mattermost.desktop
- sha512sums = d43f4adab5310a5f37bd2fcf4788af71a81ed4b384013be9a71643629ca15b9f36a2dfd77294673597a750eb8539ca9a96ad892ddb0a92290b2648ed96967c12
+ source = mattermost-package-json.patch
+ sha512sums = 45a6f1c97569fb503a319cd3766000fb8928bbb7de699751dd3d725876ddc31b72ed057ebda2f25e4369e9d940a687e7eb7fcb5dc8522a0c5857f02d6bf961bf
sha512sums = a36e5c26458a1166595b9858d2f8d40213bf7a177d86eaec1398167fbc87bcae7c3dc9416db0409b4cf4742eb497af139e2a552cdc3f1f9f9ae33f985a8511d8
- sha512sums = 5fc51cd6ee2e77a8e40736612a23e38b4649f4a2cc45f90f92fae73c396ee9d74dc5e743773fc376b52b268b482a2449212616fb4864fd79dca507d34b45c6a9
+ sha512sums = a8db88c1db7cba497ee2a1db059430d235942052322b26a2ece7a1340a28ae24686630fa89a37fcfa6bf9f277cbf8a7018ce78e7117b247b2b408fa0fb709d84
+ sha512sums = 09605ae4d5b6fe895f1ca9904984393ea7e2a3c08ca519e270d3d26fa0b14ae353c374bfd5917055f7fa3034f33a428e5bcd9b6c70c64dcbdf106a1733de023a
pkgname = mattermost-desktop
diff --git a/PKGBUILD b/PKGBUILD
index c39b064c3b88..c3f1a51b23d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Bruno Pagani <archange at archlinux dot org>
pkgname=mattermost-desktop
-pkgver=4.1.2
-pkgrel=2
+pkgver=4.2.0
+pkgrel=1
pkgdesc="Mattermost Desktop application for Linux (Beta)"
arch=('i686' 'x86_64')
url="https://github.com/mattermost/desktop"
@@ -16,16 +16,21 @@ source=(
"${pkgname}-${pkgver}.tar.gz"::"${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.sh"
"${pkgname/-/.}"
+ "${pkgname%%-*}-package-json.patch"
)
sha512sums=(
- 'd43f4adab5310a5f37bd2fcf4788af71a81ed4b384013be9a71643629ca15b9f36a2dfd77294673597a750eb8539ca9a96ad892ddb0a92290b2648ed96967c12'
+ '45a6f1c97569fb503a319cd3766000fb8928bbb7de699751dd3d725876ddc31b72ed057ebda2f25e4369e9d940a687e7eb7fcb5dc8522a0c5857f02d6bf961bf'
'a36e5c26458a1166595b9858d2f8d40213bf7a177d86eaec1398167fbc87bcae7c3dc9416db0409b4cf4742eb497af139e2a552cdc3f1f9f9ae33f985a8511d8'
'a8db88c1db7cba497ee2a1db059430d235942052322b26a2ece7a1340a28ae24686630fa89a37fcfa6bf9f277cbf8a7018ce78e7117b247b2b408fa0fb709d84'
+ '09605ae4d5b6fe895f1ca9904984393ea7e2a3c08ca519e270d3d26fa0b14ae353c374bfd5917055f7fa3034f33a428e5bcd9b6c70c64dcbdf106a1733de023a'
)
prepare() {
cd "desktop-${pkgver}"
+ # Bump dependencies. Temporary patch. Remove when 4.3 is out.
+ patch < "${srcdir}"/mattermost-package-json.patch
+
# Depending on the architecture, in order to accelerate the build process,
# removes the compilation of ia32 or x64 build.
if [[ "$CARCH" == x86_64 ]];then
@@ -34,10 +39,14 @@ prepare() {
sed -i 's/--x64//g' package.json
fi
- # Reduce build time by removing the creation of a .deb for Debian
+ # Reduce build time by removing the creation of a .deb for Debian and
+ # AppImage
sed -i -e '/"deb",/d' electron-builder.json
- # No need to compress the package
- sed -i 's/tar.gz/dir/' electron-builder.json
+ sed -i -e '/"appimage"/d' electron-builder.json
+
+ # No need to compress the package. Pay attention at the trailing comma: we
+ # are removing it from the JSON to makeit valid again.
+ sed -i 's/"tar.gz",/"dir"/' electron-builder.json
}
build() {
@@ -55,9 +64,7 @@ package() {
cp -r release/linux*unpacked/resources "${pkgdir}/usr/lib/${pkgname}"
install -Dm644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
- # SVG icon available in next release
- # install -Dm644 resources/linux/icon.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
- install -Dm644 resources/linux/icon.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${pkgname}.png"
+ install -Dm644 resources/linux/icon.svg "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
cd "${srcdir}"
install -Dm755 ${pkgname}.sh "${pkgdir}/usr/bin/${pkgname}"
diff --git a/mattermost-package-json.patch b/mattermost-package-json.patch
new file mode 100644
index 000000000000..da3b8befa3ea
--- /dev/null
+++ b/mattermost-package-json.patch
@@ -0,0 +1,76 @@
+diff --git a/package.json b/package.json
+index f5c8657..550526d 100644
+--- a/package.json
++++ b/package.json
+@@ -28,46 +28,45 @@
+ "test": "npm-run-all test:* lint:*",
+ "test:app": "cross-env NODE_ENV=production npm run build && mocha -r babel-register --reporter mocha-circleci-reporter --recursive test/specs",
+ "package:all": "cross-env NODE_ENV=production npm-run-all check-build-config package:windows package:mac package:linux",
+- "package:windows": "cross-env NODE_ENV=production npm-run-all check-build-config build && build --win --x64 --ia32 --config.extraMetadata.name=mattermost --publish=never",
++ "package:windows": "cross-env NODE_ENV=production npm-run-all check-build-config build && build --win --x64 --config.extraMetadata.name=mattermost --publish=never",
+ "package:mac": "cross-env NODE_ENV=production npm-run-all check-build-config build && build --mac --publish=never",
+- "package:linux": "cross-env NODE_ENV=production npm-run-all check-build-config build && build --linux --x64 --ia32 --config.extraMetadata.name=mattermost-desktop --publish=never",
++ "package:linux": "cross-env NODE_ENV=production npm-run-all check-build-config build && build --linux --x64 --config.extraMetadata.name=mattermost-desktop --publish=never",
+ "manipulate-windows-zip": "node scripts/manipulate_windows_zip.js",
+ "lint:js": "eslint --ignore-path .gitignore --ignore-pattern node_modules --ext .js --ext .jsx .",
+ "fix:js": "eslint --ignore-path .gitignore --ignore-pattern node_modules --quiet --ext .js --ext .jsx . --fix",
+ "check-build-config": "node -r babel-register scripts/check_build_config.js"
+ },
+ "devDependencies": {
+- "7zip-bin": "^4.0.2",
++ "7zip-bin": "^4.1.0",
+ "@storybook/react": "^3.4.6",
+- "babel-core": "^6.26.3",
+- "babel-eslint": "^8.2.3",
+- "babel-loader": "^7.1.4",
++ "babel-core": "^6.0.0",
++ "babel-eslint": "^10.0.0",
++ "babel-loader": "^7.0.0",
+ "babel-plugin-transform-object-rest-spread": "^6.26.0",
+- "babel-preset-env": "^1.7.0",
+ "babel-preset-react": "^6.24.1",
+- "chai": "^4.1.2",
+- "cross-env": "^5.1.6",
+- "css-loader": "^0.28.11",
++ "chai": "^4.2.0",
++ "cross-env": "^5.2.0",
++ "css-loader": "^1.0.1",
+ "devtron": "^1.4.0",
+- "electron": "2.0.12",
+- "electron-builder": "20.14.7",
+- "electron-builder-squirrel-windows": "~20.14.0",
+- "electron-connect": "^0.6.3",
+- "eslint": "^4.19.1",
+- "eslint-plugin-header": "^1.2.0",
+- "eslint-plugin-import": "^2.12.0",
+- "eslint-plugin-react": "^7.8.2",
+- "file-loader": "^1.1.6",
++ "electron": "^2.0.14",
++ "electron-builder": "^20.38.0",
++ "electron-builder-squirrel-windows": "^20.14.0",
++ "electron-connect": "^0.6.0",
++ "eslint": "^5.9.0",
++ "eslint-plugin-header": "^2.0.0",
++ "eslint-plugin-import": "^2.14.0",
++ "eslint-plugin-react": "^7.11.1",
++ "file-loader": "^2.0.0",
+ "mocha": "^5.2.0",
+ "mocha-circleci-reporter": "0.0.3",
+- "npm-run-all": "^4.1.3",
+- "react": "^16.4.0",
+- "react-dom": "^16.4.0",
++ "npm-run-all": "^4.1.5",
++ "react": "^16.6.3",
++ "react-dom": "^16.6.3",
+ "spectron": "~3.8.0",
+- "style-loader": "^0.21.0",
+- "url-loader": "^1.0.1",
+- "webpack": "^4.8.3",
+- "webpack-cli": "^2.1.4",
++ "style-loader": "^0.23.1",
++ "url-loader": "^1.1.2",
++ "webpack": "^4.20.2",
++ "webpack-cli": "^3.1.1",
+ "webpack-dev-server": "^3.1.4",
+ "webpack-merge": "^4.1.2"
+ }